autcomplete does not work at all for ajax login forms

RESOLVED DUPLICATE of bug 355063

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 355063
9 years ago
5 years ago

People

(Reporter: sibidiba, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

Saving usernames and passwords in Firefox is a really great feature. However, it does not work at all for forms loaded via AJAX. AJAX is a de facto web standard, often used also for login forms on many-many pages. (It allows login without page refresh.)

I have set up a mock page that loads a login form into a div via ajax on this page:
http://gablog.eu/test/ajaxlogin.html

When you log in (all usernames & passwords accepted), Firefox prompts you whether it should save the credentials. And it really does.
But when you load the page, the credentials are never ever filled in, they are not autocompleted. When you start typing the username, it is suggested, but the password is not autofilled even then.

Reproducible: Always

Steps to Reproduce:
1. Go to http://gablog.eu/test/ajaxlogin.html
2. Enter any username, password, click login
3. When Firefox asks, click save password
4. Go again to http://gablog.eu/test/ajaxlogin.html
Actual Results:  
Username/password won't be autocompleted.

Expected Results:  
Username/password should be automatically entered if you visit the site again.
Also, if you start typing the username, and it appears in the suggestion list, and you select it, the corresponding password should be also filled in into the password field automatically.

The passwords are indeed saved, they appear in the list of saved passwords. They are just not autocompleted.
You can try the plain login form, http://gablog.eu/test/loginform.html , for it will work, this is not an issue with the form, but how Firefox handles AJAX loaded forms.

Updated

9 years ago
Component: Location Bar and Autocomplete → Form Manager
Product: Firefox → Toolkit
QA Contact: location.bar → form.manager

Comment 1

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100503 Firefox/3.6.4
Able  to reproduce. Firefox is able to remember the password but credentials are not filled in username and password field the next time i visit the web page.

Comment 2

8 years ago
This is most likely a dup on bug 355063.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355063
You need to log in before you can comment on or make changes to this bug.