blackberry reply breaks threaded sorting

RESOLVED INVALID

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: artur, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

messages sorted by DATE-> ASCENDING -> Threaded

when replying to message on thunderbird or from within webmail (zimbra), threading is working consistently.  When replying to message from blackberry (bold, pearl) on BIS (tmobile, sprint). it opens a new thread with each reply.  my BIS is configured to BCC me on each reply so i receive a copy but it's sorted as a new thread.  replying to that message from within thunderbird continues the thread, but any new replies from blackberry spawns off a new thread again.

image here:
http://www.eboundhost.com/download/thunderbird.jpg

Reproducible: Always

Steps to Reproduce:
1. receive message on blackberry
2. receive bcc copy
3. opens a new thread


Expected Results:  
it should continue the original thread.  

this worked well under thunderbird 2

Comment 1

8 years ago
blackberry may not be generating reference headers, sadly. Do the messages start with re:? You may have to turn off strict threading as well, using the config editor. This will only affect newly received messages, so you may want to rebuild the index of the affected folder(s) after toggling that pref.
(Reporter)

Comment 2

8 years ago
it definitely starts with "Re:" but it also adds a lot of headers and funky return-path addresses.

After i made the change to false on 'strict threading' it started working properly.  the thing is that i like strict threading because theoretically it should avoid grouping different conversations with the same subject line.

Hope this is addressed in some other way but thank you for a quick solution!

Comment 3

8 years ago
yes, but the strict threading relies on having correct reference headers, which blackberry seems not to be generating. It's hard to have it both ways :-(

At least, messages with the same subject but w/o re: won't be threaded together.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(In reply to comment #3)
> yes, but the strict threading relies on having correct reference headers, which
> blackberry seems not to be generating. It's hard to have it both ways :-(
> 
> At least, messages with the same subject but w/o re: won't be threaded
> together.

Lotus notes did the same thing.
Artur could file a bug with RIM ?
You need to log in before you can comment on or make changes to this bug.