Status

Thunderbird
General
--
enhancement
VERIFIED WONTFIX
8 years ago
8 years ago

People

(Reporter: Manuel Lemos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.0) Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6 GTB6
Build Identifier: 

It would be nice if Thunderbird could act as a Twitter client, as well client for interacting with different types of social networks.

Reproducible: Always

Comment 1

8 years ago
That's why there are add-ons.
This would be better implemented as an extension, at least for the foreseeable future. -> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Comment 3

8 years ago
yes... for 2 reasons:
1) it's dependent on particular company who runs the servce, not an open, distributed protocol
2) it's not even email-like, but more instant-messaging-like. We'd need to have a framework for that first.

Actually.... "It would be nice if Thunderbird could act as a Twitter client". It already can! Go to Preferences, tab General, Start page, enter "http://www.twitter.com" as Location and voila, Thunderbird acts as Twitter client.

Verified WONTFIX for core, but great as extension.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

8 years ago
Twitter, Buzz and social networks in general are the new way many people are using to communicate.

It seems Microsoft recognizes that because Microsoft Outlook now has built-in support for social networks.

For users, it really does not matter if it is an extension or a built-in feature. If that feature is not present in Thunderbird, users will use something else and may end up dropping Thunderbird for good.

Comment 5

8 years ago
> Microsoft Outlook now has built-in support for social networks.

No, their linkedin-support is an add-on, too.

> For users, it really does not matter if it is an extension or a built-in
> feature.

Good, so no need to discuss. Make an extension, and provide it, and users will be happy. Given that you're ACM member, you should be capable of that.
(Reporter)

Comment 6

8 years ago
Hey, I was not arguing. I was just explaining why I think it would a good feature to add in Thunderbird after I read that Microsoft Outlook will have support for Facebook and MySpace.

The way you put it, it makes you sound arrogant and rude. I was just giving a suggestion to improve Thunderbird utility to expand to a broader range of people's communication needs.

I thought it would be useful to submit that suggestion. I am not paid for Mozilla foundation, nor I have the time and the skills to do it myself.

Your response of "go do it yourself" makes it sound as if you do want to keep away users that can only help by giving suggestions. I am sorry for bothering you. :-(

Comment 7

8 years ago
Manuel, we agree that this is a good idea. In fact, some people in the project have been talking about adding things like that - social networks, other web stuff - to Thunderbird for a long time. We're just currently busy getting the email part of Thunderbird up to 2010, e.g. nice search, fast smart folders, conversation view etc.. That's why nobody got to this nor will get to it in the next year or so.

Us marking this WONTFIX is the technical correct response. For the reasons mentioned above, it should be an extension. That doesn't mean we think it's unimportant.

My suggestion that you create that extension was worded badly, but meant seriously. We are understaffed and need contributors. Given that you're an ACM member and therefore presumably a software developer, you seemed the perfect man for the job. If you say you don't have the skills, that's fine, then maybe somebody else does it. Maybe me, if I have time. We'll see.
You need to log in before you can comment on or make changes to this bug.