Closed Bug 547182 Opened 13 years ago Closed 13 years ago

column styles (for COL element) are not applied

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 542620

People

(Reporter: me, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.20
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.2pre) Gecko/20100216 Ubuntu/9.04 (jaunty) Namoroka/3.6.2pre

Example for "background-color and color" does not work. I tested it in FF 3.5.3 and in other browsers: they do display styling for columns.

Reproducible: Always

Steps to Reproduce:
1. visit the page
2. check out the example

Actual Results:  
Example table appears unstyled.

Expected Results:  
Table columns should be styled.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: col-align-inherit
I'm not sure whether this *regression* should be marked as duplicate.
I based the dupe on bug 497269 also being duped to that.
But please do attach minimal test cases to this bug demonstrating the regression for us all to test in multiple versions to see where changes happened.
As 915 is not fixed it can't be regressed from, so we need to find the regression range to identify the bugfix that caused this regression.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I have 3.5.3 which works, and 3.6.2pre which doesn't. 
I filed simple test case. 
I cannot install nigthlies of every day between these two releases and look which one introduced the bug. 

Can you at least confirm that bug exists?
I cannot until we know if the bugfix in the 3.6 release "introduced the bug" as a regression to a previous version, or actually fixed an existing bug that should not have been allowing this to begin with.
http://ln.hixie.ch/?start=1070385285&count=1 talks about this some more, but I'll have to revisit this after getting much needed sleep.
I don't need to be on the CC list to watch this, and please stop violating http://bugzilla.mozilla.org/page.cgi?id=etiquette.html on sending private mail.
Component: General → Style System (CSS)
OS: Linux → All
Product: Firefox → Core
QA Contact: general → style-system
Hardware: x86 → All
This is already fixed on trunk, and hopefully will land in soon for  Fx 3.6
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542620
Mardeg, sorry for violating etiquette, I didn't know about this rule. I had idea that once this bug is marked as duplicate, it's buried forever, and I contacted you as the person responsible for "burying" it.

philippe, thanks for providing this information, it is much more useful!
BTW, background-color is perfectly legit for column styles, it is text color that Hixie talks about.
You need to log in before you can comment on or make changes to this bug.