Deactivation of Gloda does not remove its entry from the searchbox

RESOLVED WORKSFORME

Status

Thunderbird
Search
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

After having deactivated Gloda, its entry in the Thunderbird searchbox also disappeared as expected.
However after having restarted Thunderbird, the gloda entry ("search in all folders/accounts") appeared again in the searchbox.

So I reactivated Gloda in the preferences just for a second and deactivate it again immediatley. Again the Gloda entry in the searchbox disappeared. But only until the next restart of Thunderbird.

Also interesting:
Using the (in fact deactivated) Gloda-Search from the searchbox, the result is a new Tab that is EMPTY.
So in fact, Gloda (indexing) is deactivated in the background. But its entry in the searchbox appears again and again. And its search result is always "nothing found".



Reproducible: Always
(Reporter)

Updated

8 years ago
Summary: Deactivation of Gloda does not remove its entry in the searchbox → Deactivation of Gloda does not remove its entry from the searchbox
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

8 years ago
Confirmed here in Thunderbird 3.0.4. However, it seems to be partially fixed in Thunderbird (Lanikai) 3.1b1. By way of explanation:

* After disabling GLODA, the "Search all messages" filter option is removed from the search box, and the "Subject or From" filter becomes the default instead [1]

* Similarly, after re-enabling GLODA, the "Search all messages" filter is made available again and becomes the default

[1] With the exception of the Sent folder where, quite logically, the "Subject, To, Or Cc" filter is employed instead.

This is good, and I'm very happy that some progress has been made. Unfortunately, there remains an important corner case, which is that the search box is not adjusted correctly if the "mailnews.database.global.indexer.enabled" preference is set to false _before_ starting the program. There are two ways that I've been able to reproduce this problem:

1) Start Lanikai without an existing profile
2) Configure an account as necessary, then exit
3) Open prefs.js and add: user_pref("mailnews.database.global.indexer.enabled", false)
4) Start Lanikai again

or ...

1) Delete any existing profile, if applicable
2) Create a .cfg policy file for enforcing mandatory preferences and go through the necessary steps to make Thunderbird use it
3) Within this file, add: lockPref("mailnews.database.global.indexer.enabled", false)
4) Start Lanikai

In both cases, Lanikai will start with GLODA disabled. However, the search box will still be set to use the "Search all messages" filter, even thought it cannot be formally selected as a result of GLODA being disabled. Furthermore, when you open the combobox containing the list of available search filteres, it falsely indicates that "Subject or From" is selected (which, of course, it should be).

This is particularly egregious in the second case, because it harms those who wish to conveniently deploy Thunderbird in a corporate setting, where GLODA may not be appropriate. Admins who choose to disable GLODA using lockPref will have to go through the extra step of starting the program at least once, and explicitly switching to the "Subject or From" filter (or instructing their users to do the same).

Essentially, this bug is very close to being fixed but Thunderbird must know that if GLODA is switched off, under no circumstances should the "Search all messages" filter be shown or selected. I suppose it needs to check for this at startup. I would really appreciate it if this bug were to be completed resolved in time for the final 3.1 release.
(Reporter)

Comment 2

8 years ago
Just installed TB 3.1 beta 2 for testing purposes. And I saw, that the Quick filter bar was introduced.
Thus now when Gloda is deactivated, the searchbox disappears completely.

So I don't know if the above reported problem has been resolved (???), but at least it is invisible now.
(In reply to comment #2)
> Just installed TB 3.1 beta 2 for testing purposes. And I saw, that the Quick
> filter bar was introduced.
> Thus now when Gloda is deactivated, the searchbox disappears completely.

It's hiddent you can get it by pressing the magnifier icon.
(Reporter)

Comment 4

8 years ago
I close my bug here, since it has been "fixed" by means of:
- The Searchbox is now just used by Gloda.
- Other standard searches are not part of the searchbox any more
 (because they got their own "quick filter bar").
- The Searchbox gets hidden when Gloda gets deactivated.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.