div overflow:auto causes serious layout problem

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: matthewb, Assigned: buster)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m17) Gecko/20000807
BuildID:    20000080712

A DIV with overflow:auto inside a TD renders OK if not vertical scroll bar is
needed.  When the content is long enough that a vertical scrollbar is needed the
width of the containing TD grows uncontrollably.

We are trying hard to make Netscape 6 a fully supported browser for our design
tools.  This bug is really a blocker.

Reproducible: Always
Steps to Reproduce:
1. Try http://www.bellew.net/bug/table.html
2. Note that if you make the DIV content shorter the problem does not repro


Actual Results:  bad layout

Expected Results:  same layout regardless of length of DIV content

<html>
<head>
    <title>Scrolling DIV bug</title>
</head>

<body>

<table width=100% height=100%>
<tr>
<td valign=top style="border:2px red solid;"  height=100% width="150">
BUG: the width of the left TD expands if the content of the DIV below needs a
vertical scroll bar.<br>
<img style="border:2px purple solid;" src="x.gif" width=150 height=10>
    <div style="overflow:auto; width:132; height:500; border:2px orange solid;">
    <dl>
    <dt nowrap><img src="x.gif" width=8 height=1>AddressBook
    <dt nowrap><img src="x.gif" width=8 height=1>authors
    <dt nowrap><img src="x.gif" width=8 height=1>discounts
    <dt nowrap><img src="x.gif" width=8 height=1>employee
    <dt nowrap><img src="x.gif" width=8 height=1>From_1K_to_6K_in_order
    <dt nowrap><img src="x.gif" width=8 height=1>images
    <dt nowrap><img src="x.gif" width=8 height=1>jobs
    <dt nowrap><img src="x.gif" width=8 height=1>Log
    <dt nowrap><img src="x.gif" width=8 height=1>Mixed_Ks
    <dt nowrap><img src="x.gif" width=8 height=1>pub_info
    <dt nowrap><img src="x.gif" width=8 height=1>publishers
    <dt nowrap><img src="x.gif" width=8 height=1>roysched
    <dt nowrap><img src="x.gif" width=8 height=1>sales
    <dt nowrap><img src="x.gif" width=8 height=1>stores
    <dt nowrap><img src="x.gif" width=8 height=1>titleauthor
    <dt nowrap><img src="x.gif" width=8 height=1>titles
    <dt nowrap><img src="x.gif" width=8 height=1>types
    <dt nowrap><img src="x.gif" width=8 height=1>1_corphome.gif
    <dt nowrap><img src="x.gif" width=8 height=1>2_mywebs_userhome.gif
    <dt nowrap><img src="x.gif" width=8 height=1>3_manageweb_webhome.gif
    <dt nowrap><img src="x.gif" width=8 height=1>4_file_view.gif
    <dt nowrap><img src="x.gif" width=8 height=1>5_data_table.gif
    <dt nowrap><img src="x.gif" width=8 height=1>6_tips_tab.gif
<!-- cut here to make list shorter, if no vertical scrolling is required, bug
goes away -->
    <dt nowrap><img src="x.gif" width=8 height=1>7_view_editor.gif
    <dt nowrap><img src="x.gif" width=8 height=1>asdf.view
    <dt nowrap><img src="x.gif" width=8 height=1>blank.view
    <dt nowrap><img src="x.gif" width=8 height=1>debug.view
    <dt nowrap><img src="x.gif" width=8 height=1>default.css
    <dt nowrap><img src="x.gif" width=8 height=1>default.html
    <dt nowrap><img src="x.gif" width=8 height=1>default.view
    <dt nowrap><img src="x.gif" width=8 height=1>gfdfg.html
    <dt nowrap><img src="x.gif" width=8 height=1>giving.gif
    <dt nowrap><img src="x.gif" width=8 height=1>html.view
    <dt nowrap><img src="x.gif" width=8 height=1>master.view
    <dt nowrap><img src="x.gif" width=8 height=1>raid.mdb*
    <dt nowrap><img src="x.gif" width=8 height=1>search.view
    <dt nowrap><img src="x.gif" width=8 height=1>test.ws
<!-- end cut here -->
    </dl>
    </div>
</td>
<td style="border:2px blue solid;" height=100% width="100%"><img
style="border:2px purple solid;" src="x.gif" width=300 height=10></td>
</tr>
</table>

</body>
</html>

Comment 1

18 years ago
*** Bug 54733 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Confirmed, build 2000-09-30-08-M18 on Windows 98 SE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Dividing up claytons bugs to triage
Assignee: clayton → dcone

Comment 4

18 years ago
Seems to be a layout problem.
Assignee: dcone → buster
(Assignee)

Comment 5

18 years ago
somebody must have already fixed this, because it seems to work fine now.
WinNT, commercial build ID=2000101008
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.