If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crashes with upload of large files

RESOLVED DUPLICATE of bug 542120

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 542120
8 years ago
8 years ago

People

(Reporter: u374307, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6; Mozilla/4.0(Compatible Mozilla/4.0 ; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: 3.6 (replaced it with 3.5 so don't have build number but it is the most recent)

I am a developer working with FCKeditor.  When uploading large files (say 2 megs) using the FCKeditor's file browser, Firefox crashes (Windows). Initially, I eliinated all add-ons and found it happened with HTML Validator, but then I disocvered it happens with or without that add-on when large files are uploaded.  I reverted to 3.5 and this doesn't happen. Nor does it happen on OS X, using 3.6.  Nor does is happend in IE on Window or Safari on Windows.  

Reproducible: Always

Steps to Reproduce:
1.  Open the FCKeditor's file brower -- not the quick upload tab
Click on browse, then in the file browser click on  the browser button at bottom of screen   
2  Select a file greater than 2 megs for upload and click upload

Actual Results:  
Browser crashes and bug reporting window appears.  I sent one in but at the time thoought the issue was with HTML Validator.  My guess is that HTML Validator is invovled only in so far as it consumes memory.  


The issue is not on the server side:
1.  php.ini is set up to accept large files
2.  even if that were the problem, the server might be expected to show some error activity (there's nothing in the apache error logs), but you wouldn't expect the browser to crash.

I'm just guessing, but I have a feeling the browser is failing to handle large uploads. 

This may be the same problem as those reporting that they cannot upload image to facebook.
we need a crash ID : https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 2

8 years ago
I did ssend in a crash report from the popup window that appeared when the crash occurred.  If you keep track of the IP addresses from which these reports come and from which the crash reportes come, you can match them up.
IP addresses are not logged, we only need the crash id from about:crashes
(Reporter)

Comment 4

8 years ago
retrieved from about-crashes:

http://crash-stats.mozilla.com/report/index/bp-7e1ae25c-7781-4b40-b40f-8953f2100219
Do you have Firebug installed ?
That would be bug 542120
(Reporter)

Comment 6

8 years ago
Yes
thanks, marking as dupe of bug 542120
(that is marked invalid because it's a firebug bug)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542120
(Reporter)

Comment 8

8 years ago
Thank you.  I'll re-install 3.6 and see what happens.

Comment 9

8 years ago
reinstalling wouldn't fix it. you need a newer firebug.
(Reporter)

Comment 10

8 years ago
Installed ff 3.6 with firebug 1.5.2 and all seems to be working.  The firebug web site refers to this bug and rates it as fixed in 1.5.1.  Thanks for your help.
You need to log in before you can comment on or make changes to this bug.