account user is modified when login in server

RESOLVED DUPLICATE of bug 306035

Status

Thunderbird
Account Manager
RESOLVED DUPLICATE of bug 306035
9 years ago
9 years ago

People

(Reporter: herve cimadomo, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.15) Gecko/2009101601 Firefox/3.0.15 GTB6 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.19 (20081209)

I have already several imap account that work properly. I try to create a new and when i try to get new message, the account used is the account username is added by the imap host ( imap host = ns0.ovh.net, user is xxxx.yyyy@mydomain.com and the user used by thunderbird for getting new messages is xxxx.yyyy@mydomain.com@ns0.ovh.net ).
is anybody have a explication ( and solution :) )?
thank

Reproducible: Always
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0
Well I don't understand your issue - If it's easier write that description in French - once I understand the issue we'll continue in english.
(Reporter)

Comment 2

9 years ago
bonjour, je souhaite rajouter un compte de messagerie de type imap. Je passe comme d'habitude par l'assistant. Je configure le serveur (ns0.ovh.net) et le login imap (herve.cimadomo@ulysse-solutions.com). 
lorsque je veux lire mon dossier "courrier entrant", j'ai une demande de mot de passe pour le login herve.cimadomo@ulysse-solutions.com@ns0.ovh.net. Bien entendu, ca ne marche pas puisque le login n'est pas correct. C'est un comportement nouveau (ce n'est pas le premier compte imap que je crée).
j'ai mis dans une piece jointe les copie d'ecran de ma configuration serveur et le pop-pup demandant le mot de passe du mauvais login)

salutations
(Reporter)

Comment 3

9 years ago
Created attachment 428214 [details]
screen copy to show serveur conf and popup box for password with bad login
Issue is that Thunderbird is prompting password for a bad user name (user@email@server).

Hervé we'll continue in English from now on.

When you say it doesn't work - what error message do you get when you type in your password ?

Screen shot show ssl0.ovh.net, not ns0 ... and if you use ssl you might want to use it with the correct port 993 instead of 143 (and check the ssl radio button below).

Are your other imap servers also domains hosted @ OVH , or are they gmail emails ?
(Reporter)

Comment 5

9 years ago
Ludovic,
The server and port is correct. I've verified by using telnet command (telnet ssl0.ovh.net 143  ----> * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE AUTH=PLAIN ] Welcome to OVH Mail server 645 )
The user id for my new account is "herve.cimadomo@ulysse-solutions.com".
The popup box when i want to see messages in inbox folder ask a password for user "herve.cimadomo@ulysse-solutions.com@ssl0.ovh.net".
When  i type my password , i have following message : in french "la connexion au serveur ssl0.ovh.net a échoué".
I have other imap account: one with free (server = imap.free.fr , port 143) and two with gmail (server= imap.gmail.com port 993 (ssl)).

Is it possible to activate log ?

thank.
Duplicate of this bug: 547679
Is this a duplicate of bug 306035?
(In reply to comment #7)
> Is this a duplicate of bug 306035?

Could be.

(In reply to comment #5)
> Ludovic,
> The server and port is correct. I've verified by using telnet command (telnet
> ssl0.ovh.net 143  ----> * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR
> LOGIN-REFERRALS ID ENABLE AUTH=PLAIN ] Welcome to OVH Mail server 645 )
[snip] 
> Is it possible to activate log ?

yes. See https://wiki.mozilla.org/MailNews:Logging to get the logs. But we strip logging information from that. At least that will give us the error message sent by the server.
(In reply to comment #0)
> ( imap host = ns0.ovh.net, user is xxxx.yyyy@mydomain.com
> the user used by thunderbird for getting new messages is xxx.yyyy@mydomain.com@ns0.ovh.net )

xxx.yyyy@mydomain.com@ns0.ovh.net is string at password dialog, isn't it?
If so, it means "xxx.yyyy@mydomain.com AT ns0.ovh.net" and is dup of bug 306035.
(Reporter)

Comment 10

9 years ago
well, it's seem that is effectively the bug 306035. now that lighning's extension work on TB 3, i decided to migrate to TB 3. Now, the username is correct and the account work as well than others. 
I'm veru impressed by the quality to TB 3. congratulation to all contributors.
dup per comment #10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 306035
You need to log in before you can comment on or make changes to this bug.