Public version of P2PU project displays wrong project details

RESOLVED FIXED

Status

Websites Graveyard
www.drumbeat.org
--
blocker
RESOLVED FIXED
9 years ago
4 years ago

People

(Reporter: Mark Surman, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
The public version of the P2PU project displays the wrong project details. When you visit this page:

http://drumbeat.stage.mozilla.com/project/p2p-university-open-web-career-track

and you are NOT LOGGED IN, you actually see the project details for this project:

https://drumbeat.stage.mozilla.com/project/local-drumbeats-event-kit

This seemed to happen when I 'joined' the P2PU project.

Updated

9 years ago
Assignee: nobody → vertesi

Comment 1

9 years ago
We're having trouble reproducing this bug at this point. 
(although i was able to reproduce it yesterday)
Can someone else confirm / reproduce this bug?

Updated

9 years ago
Severity: critical → major

Comment 2

9 years ago
Same problem here, but I'm logged in.
(Reporter)

Comment 3

9 years ago
Created attachment 428908 [details]
Screenshot of the problem
(Reporter)

Comment 4

9 years ago
Seems like the P2PU item is fixed / working now, but I am seeing the same problem with the Local Drumbeat Events project. When I am a normal user, the project details for this project:

https://drumbeat.stage.mozilla.com/project/local-drumbeats-event-kit

are replaced w/ the details from this project

http://drumbeat.stage.mozilla.com/project/p2p-university-open-web-career-track

So, this is the reverse of the original bug. Also, given Hans' note above, looks like this problem may be not only for anon users but for anyone who is not admin or project owner?
Severity: major → critical

Comment 5

9 years ago
@Mark 

I was able to reproduce the problem  you mentioned above as an ordinary authenticated user . 
The problem does not occur for anonymous or administrative users. 

Investigating ..

Comment 6

9 years ago
Show correctly after flushing the cache.

I would investigate caching @
https://www.drumbeat.org/admin/build/block/configure/views/project_tabs-block_9?destination=node%2F1839

Best,
Paul Booker

Updated

9 years ago
Duplicate of this bug: 548575

Comment 8

9 years ago
I just noticed a similar issue on a different project page.

The Privacy Icons page is displaying completely different information for admin than for anonymous users. 

http://www.drumbeat.org/project/privacy-icons
Severity: critical → blocker
This may well all have been symptoms of bug 548392, a bug in one of the cache modules, which is now fixed on staging (but not yet in production).

Gerv

Comment 10

9 years ago
Have tested on staging server. Looks fixed. Asking Gerv or Jeremy Orem to run SVN update from staging to production to commit fix.

Comment 11

9 years ago
SVN update complete. Just tested. Looks fixed to me! :)
Assignee: vertesi → nobody
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.