Miro should not be featured on mozilla.com - terrible install experience

VERIFIED FIXED

Status

P2
major
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: mats, Assigned: abuchanan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
(apologies if this is not the right way to report this)
I don't know anything about the issue, I'm just forwarding
this Hendrix feedback:

Name:    
Product: Firefox
Summary: Miro is full of Spyware

Comments: 
The Miro add on you are offering is full of sp6yware, makes unauthorized
registry changes, and a host of other crap (Why does it need to change
my start up page???). 
It is needlessly difficult to remove. I think continuing to promote it
as a Firefox add on is a Big mistake. 

Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
From URL: http://hendrix.mozilla.org/
The only add-on I can find with the word 'Miro' in its title when I search for 'miro' is "I (Heart) Miro":
https://addons.mozilla.org/en-US/firefox/addon/6635
I just did a quick code review, and it's completely harmless. All it does is add a referral code to Amazon urls. It doesn't do anything else.

I'm pretty sure what the answer will be but, is there any more information about this?
(Reporter)

Comment 2

9 years ago
Here's another Hendrix report on Miro with similar claims;
I have contacted the user asking for additional information.

Name:    
Email:   farrellwatverizondotnet
Product: Firefox
Summary: Miro control and usage

Comments: 
Downloaded and installed latest version of Firefox. Also at the prompt
downloaded and installed Miro. Subsequently, My Home page was changed to
the Miro site and attempts to change this were unsuccessful. Could not
open Tools/options to reset my homepage. Returned to Firefox via URL but
all was frozen. Closed down Computer. On startup I noticed Firefox safe
mode. I returned everything to default. Worked! I went thru all of
because I could not remove miro from my computer. Seems like it worked
like a virus. Just kept getting more miro files. Miro would not
uninstall even thru the add/removal option in the control panel. I use
windows 7 on a late 2009 Toshiba laptop.  
Thank you,
Farrell Winkleblack
8183630428



Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
From URL: http://hendrix.mozilla.org/
(Reporter)

Comment 3

9 years ago
Is the following SUMO thread about the same Miro?
http://support.mozilla.com/en-US/forum/1/550343
(Reporter)

Comment 4

9 years ago
Is this the Miro application they talk about?  http://www.getmiro.com/
Perhaps installing this application also adds an add-on in Firefox that the
user does not see until they restart, for example for a Firefox update?
I've installed the Miro application on Windows, and I can confirm that the default install messes up Firefox 3.6 and 3.5, badly. The default search in the location bar leads the user to http://www.mirostart1.com, and all search engines are removed from the search bar (!!!), I'm guessing because of some bug in their search engine modification code. This happened to me in Windows 7 64 bit.

This behavior without user consent is absolutely unacceptable.

There's nothing that can be done by AMO since this is not an add-on, but I think that Miro should be removed from all recommendations in mozilla.com and .org. I'll try to reassign this to the right component.
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Add-on Security → www.mozilla.com
Ever confirmed: true
Priority: -- → P2
Product: addons.mozilla.org → Websites
QA Contact: security → www-mozilla-com
Summary: Miro is full of Spyware → Miro should not be featured on mozilla.com - terrible install experience
They're at least on http://www.mozilla.com/en-US/firefox/central/, too.
John, do you have a contact at PCF that can take a look at this or know anything about these search provider problems? see comment #5 for a summary

Comment 8

9 years ago
Yep. Let me get to them and get them involved here.

Comment 9

9 years ago
Hi everyone,

I run the Miro project. We recently moved to a new search partnership and we've found a couple bugs in the search tools and have been tweaking the process generally.  We've already asked the partner provider to make several changes, most of which are done and should be going live this week or next, which will: make the search partnership choice more clear on install, fix the search choice locking bug (which is rare, as we understand it), and make uninstall more standard with clearer instructions.

I hope these changes will address most of the concerns above, which we share. Like other consumer open-source projects, search partnerships are the best (and maybe the only) way we can afford to develop a popular free and open product. We really want to find a way to make this a positive experience for everyone and to keep our non-profit work alive.  

nicholas - nicholas@pculture.org
(Assignee)

Comment 10

9 years ago
Who is taking charge of verifying these problems are fixed?  Is there any action needed for mozilla.com web pages (i.e. removing Miro promo)?
Slater, do you know who managed the selection of the apps featured on http://www.mozilla.com/en-US/firefox/central/ ? That person (or you!) should decide if this bug is serious enough to remove Miro, at least until it's fixed. I haven't seen the bug firsthand but the description above about removing all of the search engines is pretty scary.

Comment 12

9 years ago
(In reply to comment #11)
> Slater, do you know who managed the selection of the apps featured on
> http://www.mozilla.com/en-US/firefox/central/ ? That person (or you!) should
> decide if this bug is serious enough to remove Miro, at least until it's fixed.
> I haven't seen the bug firsthand but the description above about removing all
> of the search engines is pretty scary.

That content was determined by a variety of people, but mainly me, pkim & beltzner. I don't recall who specifically added Miro (my guess would be pkim), but it sounds like we should pull promo until the problems have been resolved

Alex, can you remove the promo from the Getting Started page today? No need to replace it with anything else at the moment - we can just add Miro back in when ready.

Nicholas, let us know when the bugs have been resolved.

Thanks all-
Assignee: nobody → buchanae
(Assignee)

Comment 13

9 years ago
Will do.  

Note:  this page is localized, so it affects many locales.

Comment 14

9 years ago
(In reply to comment #13)
> Will do.  
 
Thanks Alex!

> Note:  this page is localized, so it affects many locales.

Good point, although it's also worth noting that we also encouraged the localizers to choose sites & services that were more relevant to their specific locale, so the content on the en-US version isn't necessarily repeated everywhere.

Comment 15

9 years ago
Hi all-- i totally understand if you want to remove this pending the fixes I outlined.  Just to let you know, we're planning to have a new Miro release by monday that will fix these problems (and is also a major update to the application).
(Assignee)

Comment 16

9 years ago
r63174 on trunk
r63178 on stage
(Assignee)

Comment 17

9 years ago
Closing so QA can verify before I push to production.  

Reopen when it's time to put the promo back up.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified on Staging at https://www.authstage.mozilla.com/en-US/firefox/central/#feature-connect
Status: RESOLVED → VERIFIED
(Assignee)

Comment 19

9 years ago
r63188 on production

Comment 21

9 years ago
Hi Again,

I wanted to let everyone know that we fixed the search locking bug referenced at the beginning of this thread a few weeks ago.  I've waited to post here because with the release of Miro 3.0 last week we've also made 5 or 6 additional improvements, many of the ideas for which came from conversations with Asa Dotzler, which make the install experience, search partnership offer, and uninstall process much more clear and more streamlined. I think it's pretty solid at this point and we've had it in the wild for almost a week now, with no major problems discovered.

We would love to return to the recommended page, it's been a big help for our organization.

Take care,

nicholas

Comment 22

9 years ago
Nicholas, thanks for the update. We're reviewing and will get back to you as soon as possible.

Comment 23

9 years ago
Just filed bug 556406 to add the Miro promo back to the site. Any further discussion should take place over there.

Thanks all-
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.