Closed Bug 547618 Opened 12 years ago Closed 12 years ago

Firefox crashes when I print this page to OSX Preview

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 534672

People

(Reporter: cwr, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Running Firefox 3.6 on OSX 10.6.2 I browsed this page:

http://gamesfromwithin.com/data-oriented-design

then tried to print it using the Preview button at the bottom of the Print dialog.  Firefox crashed.  That's weird.  I relaunched Firefox and tried it again.  It crashed again, which is weirder.  I tired the same thing in Safari 4.0.4 and had no problem.

I have (ahem) *lots* of tabs open.

Reproducible: Always

Steps to Reproduce:
1. browse http://gamesfromwithin.com/data-oriented-design
2. [File / Print...]
3. [Preview] button at bottom
Actual Results:  
Firefox crashes

Expected Results:  
Firefox doesn't crash
Hi, thanks for your attention.  After I filed the report I found Crash Reporter windows buried under some other apps.  I supplied this bug number with at least one of those reports.  The top entries in about:crashes are from yesterday:

  Submitted Crash Reports
  Report ID                               Date Submitted
  bp-87ca0cd1-df13-4c01-bd7c-d4ca72100222	2/22/10	9:15 AM
  bp-59bdc0b0-1fcb-4534-8e5a-667712100222	2/22/10	9:10 AM

the latter one lists:

  Related Bugs
  OPEN
  534672 NEW Print crash on Mac OS X 10.6 Snow Leopard [@ layout_flush_block],
         with gfx.force_atsui_text turned on

Let me know if I can provide additional details.

Craig
http://www.red3d.com/cwr/
duping 

the other crash is unusable.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534672
I can't reproduce this crash myself as it only occurs on OSX 10.6.

It would be interesting to see a larger set of crash data here --
does it always crash with "Crash Address: 0x4"?
You need to log in before you can comment on or make changes to this bug.