If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot install experimental search plugins unless logged out

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Search Plugins
--
major
RESOLVED INVALID
8 years ago
2 years ago

People

(Reporter: Brian, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I cannot install any experimental search plugins unless I log out of my account and then check the box that says "Let me install...". This only happens with experimental XML search plugins, not XPI extensions. And it only happens when I'm logged in, which seems completely backwards. I don't know if this has to with with bad cookies or a programming bug because when a user is logged in, I thought they should be able to download anything.


Reproducible: Always

Steps to Reproduce:
TO FAIL:

1. Log in to my account
2. Search for any experimental search pluging (see sample URL)
3. Click on "Add To Firefox"

TO SUCCEED:

1. Log out of my account
2. Search for any experimental search pluging (see sample URL)
3. Check box "Let me install..."
4. Click "Add To Firefox"

Actual Results:  
"Firefox could not download the search plugin from..."

Expected Results:  
It should bring up the confirmation to install.

Comment 1

8 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

WFM. No problems installing TweetNews 20090123 while logged in, either from its page or from the search page itself.
https://addons.mozilla.org/en-US/firefox/addon/10478

Are you sure it's with all experimental search plugins or just certain ones?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
> 
> WFM. No problems installing TweetNews 20090123 while logged in, either from its
> page or from the search page itself.
> https://addons.mozilla.org/en-US/firefox/addon/10478
> 
> Are you sure it's with all experimental search plugins or just certain ones?

Someone in another forum came up with the solution. Third-party cookies must be enabled for everything to work. I'm glad this is not a bug, but disappointed that I must let hundreds of unwanted cookies in. Sorry for the confusion, and thanks for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.