Bookmarks will not sync

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: mstuff, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8) Gecko/20100216 Fedora/3.5.8-1.fc11 Firefox/3.5.8
Build Identifier: v 1.01

I have complex bookmarks on 2 installations - weave will not do any synchronisation of bookmarks on either installation

Reproducible: Always

Steps to Reproduce:
1. Install weave on both installations
2. Select to sych bookmarks
3. Bookmarks not syched
Actual Results:  
Bookmarks not synched

Expected Results:  
Bookmarks synched - somehow, they'll need merging

Merged bookmarks on both machines and kept them synchronised
(Reporter)

Comment 1

9 years ago
Created attachment 428109 [details]
ActivityLog

ActivityLog up to bug filing
(Reporter)

Updated

9 years ago
OS: Linux → All
Hardware: x86 → All

Comment 2

9 years ago
Created attachment 433953 [details]
weave log extract from winxp

Comment 3

9 years ago
 Bookmarks will not sync  

I installed weave 1.1 on the following:

Firefox 3.6 on Winxp sp3
Firefox 3.5.8 on Opensuse 11.2

I added extracts of the logs for each

the winxp log shows errors and the linux log looks nearly identical to that attached by Morgan Read

I hope someone  can help as this is a funtion I have been looking for and it would be nice for it to work

Comment 4

9 years ago
Created attachment 433958 [details]
extract of log from opensuse

Comment 5

9 years ago
Comment on attachment 433953 [details]
weave log extract from winxp

>2010-03-22 11:19:55	Service.Main         DEBUG	Exception: Clients.getClients()[Clients.clientID] is undefined JS Stack trace: ()@service.js:1142 < WrappedNotify()@util.js:114 < WrappedLock()@util.js:86 < WrappedCatch()@util.js:65 < sync()@service.js:1080 < (60)@sync.js:286
This seems related to bug 548066.

Updated

9 years ago
Depends on: 548066

Comment 6

9 years ago
Does restarting Firefox help this issue? Seems like it's the winxp machine running into the "is undefined" exception.

Comment 7

9 years ago
I have a similar situation except I have 3 clients. Today I added few bookmarks and it seems they are not uploaded. I logged onto another client, waited for weave to connect and sync and checked bookmarks. The new bookmarks are not present.
I also tried to manually disconnect and reconnect weave and asked it to sync manually. No result. I thought it might be a problem with Firefox Namoroka. Then I tried to create another user, install the latest stable Firefox version and installed the same latest weave version as on other clients and wait for it to sync. Again, no luck. I got all the bookmarks, except the few ones I added on the first machine. It is now clear they are NOT uploaded.
Now, this is very annoying and I have few questions:
1) How do I force weave to upload NEW bookmarks?
2) How do I MAKE SURE they've been REALLY uploaded?

Updated

8 years ago
Component: Needs Triage → General
QA Contact: needstriage → general
If this is still occurring, please file a new bug.  I suspect bug 548066 was teh culprit at the time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.