Unable to register for a new account, as email is not validated

NEW
Unassigned

Status

9 years ago
9 years ago

People

(Reporter: tuggyne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
While investigating for bug 547493, I discovered that I was unable to register for a new account -- https://support.mozillamessaging.com/tiki-register.php?locale=en-US gives an error on form submission, claiming that my email address cannot be validated. I do not receive any validation email.

STR:
1. Visit https://support.mozillamessaging.com/tiki-register.php?locale=en-US
2. Fill in username, password, email, and CAPTCHA code
3. Click Register

Expected:
Validation "next-steps" page to appear, asking me to check my email to continue.

Actual: An error form appears, asking me to reenter my email address for validation. Upon submittal, the same form reappears and asks me to reenter my email address again. This appears to loop infinitely.
Are there any non-alphanumeric characters in the email address you're using?
(Reporter)

Comment 2

9 years ago
Other than the at sign and the periods, no. My email address (copied and pasted just now) is `bugzilla@nathan.tuggycomputer.com` (no backquotes).
If anyone has an opportunity to test before we get a chance to dig into this, my hunch is that it's choking on the second dot in the domain.
(Reporter)

Comment 4

9 years ago
So it would seem: registering with nathan@tuggycomputer.com works just fine. Reducing severity a bit accordingly.
Severity: major → normal
OS: Windows Vista → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.