Address auto-complete gives incorrect order, not based on frequency after upgrading from Thunderbird 2 to Thunderbird 3 (autocomplete)

RESOLVED DUPLICATE of bug 497722

Status

--
major
RESOLVED DUPLICATE of bug 497722
9 years ago
9 years ago

People

(Reporter: panther, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird/3.0.1

Bug 497722 claims to have fixed a problem with randomness which I have not observed. I have observed a consistent ordering of the email addresses which is not based on frequency. The email addresses I use every day are no longer at the top.

Reproducible: Always

Steps to Reproduce:
1. Upgrade from Thunderbird V2.x to V3.0.x
2. Select Write to start entering a new email
3. Type a few letters of intended recipient in the To: field
Actual Results:  
Some email address is chosen that is not the most frequently used.

Expected Results:  
The email address selected in V3 should be the same email address as in V2.

This is very dangerous as it could lead to sending emails to unintended recipients based on habits from using V2.

At a minimum a function to reset the sort order should be added.
Exactly which version of Thunderbird 3 are you using?

(In reply to comment #0)
> Build Identifier: Thunderbird/3.0.1

If you are using 3.0.1 this bug is invalid. Bug 497722 has only been fixed in 3.0.2 and later.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497722
You need to log in before you can comment on or make changes to this bug.