If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Server date/time input into modified field in windows but local PC time input into modified field in linux when saving an image

UNCONFIRMED
Unassigned

Status

()

Firefox
File Handling
UNCONFIRMED
8 years ago
7 years ago

People

(Reporter: Steve, Unassigned)

Tracking

3.6 Branch
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

If I right click an image and save it to disk, under windows the SERVER date is put into the date modified field, but under linux the PC date is put into date modified field. ALL other browser including firefox3.6 put the PC date into the date modified field on the PC.  This only happens on the WINDOWS build and is OK on the linux build

Reproducible: Always

Steps to Reproduce:
1.right click and save an image
2.check the modified date and its WRONG, it's the server date instead of the PC
3.
Actual Results:  
1.right click and save an image
2.check the modified date and its WRONG, it's the server date instead of the PC

Expected Results:  
1.right click and save an image
2.check the modified date and it should be the PC's local time and date and NOT the servers date

this always used to be the case until the last few builds of minefield. This is OK under linux but under windows the server date get put into the modified date field unstead of the PC's local time/date.

Comment 1

8 years ago
I thought it was just me setting something wrong, I too have this problem. In windows XP SP3.
The behavior change is now correct in Windows and it is now the way FTP software has always worked when downloading files from the internet or moving/copying files around on the OS.  So the change that was put into to place to make it correctly use the same behavior as the OS and FTP software which has been around longer than browsers.  

Browsers have always gotten the copy/move download behavior wrong, even if we don't like it that way :) 

FWIW, I heard that someone could make an extension for firefox to change the behavior back to the incorrect browser behavior we've had for years. 

I believe it is because when you download, your actually creating a copy of the original server file, not modifying it.

Comment 3

8 years ago
This is not a bug as the behaviour was changed (as Dale pointed out) here: https://bugzilla.mozilla.org/show_bug.cgi?id=178506

The platform should be linux - if the modification time/date bug really does reside there at all - not Windows.
(Reporter)

Comment 4

8 years ago
Ok Thanks for that, then the Linux version is wrong, although people running linux in the mozillazine said it was correct so I just assumed that the windows version was broke and not the linux version, as EVERY other browser also acts the same as the linux version of mozilla.

I REALLY hope that somebody write an extension then as I would like to continue to do things the same way I have for the past 15+ years.
I too would like to go back to the way other browsers do things, as firefox or minefield is a browser with built in ftp and not a dedicated ftp client. I use firefox 3.6 also with minefield and firefox also saves differently to minefield. So does that mean that firefox is broke and if so is it too going to get fixed.  I too run XP service pack 3 and would like to arrange my files like i have all my computing life by arranging my document by date modified and not having to go searching through my documents for a file that has just been downloaded. I agree with steve in the hope that some bright spark write an addon to bring it inline with other browsers.

Comment 6

8 years ago
Can't you just do a sort on date created instead of modified?
Non-windows systems (i.e. Linux, and AFAIK Max OSX) don't support file creation date. They only support accessed and modified dates.

IMHO preserving the file metadata from the server is the correct thing to do, but I think that it should be optional (enabled by default) as it does change a long-standing behavior.

(In reply to comment #4)
> Ok Thanks for that, then the Linux version is wrong, although people running
> linux in the mozillazine said it was correct

In the context of Bug 178506, Linux is functioning correctly. It is preserving the modified date from the server. This is the intended behavior.
(Reporter)

Comment 8

8 years ago
If you look at this picture http://i49.tinypic.com/1zdaxyt.jpg Obviosly LINUX or WINDOWS build is WRONG, as they both do something DIFFERENT.
(Reporter)

Comment 9

8 years ago
they BOTH can't be OK if they BOTH builds are saving the SAME file with DIFFERENT dates.
http://files.bluefang-logic.com/images/ff_mod_date.png

I ran a test. There is a 3 hour difference, but I think that is just the differences in timezone between my computer (EST) and the server (probably PST). So it looks correct to me.
(Reporter)

Comment 11

8 years ago
NO, this works OK for FILES downloaded, it's when you right click and image and select SAVE IMAGE, like I said in the bug report to reproduce you load and image and then right click it and save it. On windows it gets the server time/date on the linux build it get the local time, just like in this picture. http://i49.tinypic.com/1zdaxyt.jpg
Thats Linux, IE, and minefield in that order.
As Far as I know saving files is correct on both builds as I use a download manager for files.
Ok, I did some more tests.

Top row is right-click -> save image as on the previous image I posted
Bottom row is right-click -> save image as on the text logo (top-left) from MozillaZine Forums

Left is Minefield on Linux
Center is Minefield on Win7 RC1
Right is IE8 on Win7 RC1

http://files.bluefang-logic.com/images/ff_mod_date_2.png

Comments:
- IE8 is using the system time

- Minefield times match on my image. They are off by 1 hour on the MozillaZine logo image. Don't really have an explanation for the discrepancy, but it seems like a minor bug.
There are two other bugs open, one for the download manager code and one deeper than that.  One is an edge case, the other is off by an hour I think.
(Reporter)

Comment 14

8 years ago
(In reply to comment #12)
> Ok, I did some more tests.
> 
> Top row is right-click -> save image as on the previous image I posted
> Bottom row is right-click -> save image as on the text logo (top-left) from
> MozillaZine Forums
> 
> Left is Minefield on Linux
> Center is Minefield on Win7 RC1
> Right is IE8 on Win7 RC1
> 
> http://files.bluefang-logic.com/images/ff_mod_date_2.png
> 
> Comments:
> - IE8 is using the system time
> 
> - Minefield times match on my image. They are off by 1 hour on the MozillaZine
> logo image. Don't really have an explanation for the discrepancy, but it seems
> like a minor bug.

as you can see on your ENTIRE top row the date modified for all programs the modified date is indeed you PC's clock.
(In reply to comment #4)
> 
> I REALLY hope that somebody write an extension then as I would like to continue
> to do things the same way I have for the past 15+ years.

see https://addons.mozilla.org/en-US/firefox/addon/93121/
This should be resolved INVALID by Bug 178506

Updated

7 years ago
Version: unspecified → 3.6 Branch
You need to log in before you can comment on or make changes to this bug.