All Folders pane scrolls down when message is opened then closed

RESOLVED DUPLICATE of bug 257704

Status

--
minor
RESOLVED DUPLICATE of bug 257704
9 years ago
9 years ago

People

(Reporter: babrown, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

I use two panes - All Folders on left and the email list on the left (no message pane). If I open a message, it opens a new tab (by the way I wish I had the old option, don't like this) then when I close the message tab, the All Folders pane has scrolled half way down my screen. I am constantly moving it back up to the top where I want it. I don't know if this happens on Vista because I won't update Thunderbird due to the tabbed messages. I prefer the old way.

Reproducible: Always

Steps to Reproduce:
You have to have a lot of folders in the "All Folders" pane - more than will fit in a single screen so you have to scroll down.
1. Set to two panes - All Folders on left and the email list on the left
2. Open an email message
3. Close message
4. All folders will be scrolled down half way
Actual Results:  
All Folders pane has scrolled half way down my screen

Expected Results:  
Leave scroll bar where it was when I opened message
(In reply to comment #0)

> the old option, don't like this) then when I close the message tab, the All

You have in Tools -> Options -> Advanced -> Reading and display you can choose to open in a tab, in a new window in an existing window.

Aureliano is this a dup of some other bugs we already have ?

Comment 2

9 years ago
I have the same problem (probably), but it doesn't require that you close the message.  

If I leave the main view to read a message in a new tab, the main view's  scrollbar position is changed to put the currently selected mailbox folder as high up the screen as possible.

Imagine if Firefox did stuff like this... resetting the scroll bar for each tab when you navigate away from it...  Even small inconveniences get really annoying if they happen all the time.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4
See bug #257704 comment #1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 257704
You need to log in before you can comment on or make changes to this bug.