crash [@ libPDFRIP.A.dylib@0x181c2 ] [@ layout_flush_block]

RESOLVED DUPLICATE of bug 534672

Status

()

--
critical
RESOLVED DUPLICATE of bug 534672
9 years ago
8 years ago

People

(Reporter: mike001, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
crash [@ libPDFRIP.A.dylib@0x181c2 ]

#9 crash for Macs, not in top 100 overall (total 67, all Mac, Jan26-Feb22)
3.0 - 13 occurrences, all MacOS 10.6.2 (10C2234)
3.0.1 - 54 occurrences, 8 MacOS 10.6.1 (10A2155), 46 MacOS 10.6.2 (10C2234)
(no occurrences for 1.9.2 or 1.9.3 branches)

bp-96a6ad0f-bbdb-4bc4-b64e-afa1e2100222  v3.0.1  Build20100111130305
comment: Crash when trying to print a mail with attachments.
0	libPDFRIP.A.dylib	libPDFRIP.A.dylib@0x181c2	
1	libPDFRIP.A.dylib	libPDFRIP.A.dylib@0x189a5	
2	libPDFRIP.A.dylib	libPDFRIP.A.dylib@0x318c	
3	libPDFRIP.A.dylib	libPDFRIP.A.dylib@0x3db1	
4	libRIP.A.dylib	libRIP.A.dylib@0x3299f	
5	CoreGraphics	CoreGraphics@0x2ff91	
6	CoreGraphics	CoreGraphics@0x2f8e6	
7	thunderbird-bin	_cairo_quartz_surface_show_glyphs	gfx/cairo/cairo/src/cairo-quartz-surface.c:2124
8	thunderbird-bin	_cairo_surface_show_text_glyphs	gfx/cairo/cairo/src/cairo-surface.c:2305
9	thunderbird-bin	_cairo_gstate_show_text_glyphs	gfx/cairo/cairo/src/cairo-gstate.c:1620
10	thunderbird-bin	_moz_cairo_show_glyphs	gfx/cairo/cairo/src/cairo.c:3170
11	thunderbird-bin	gfxFont::Draw	gfx/thebes/src/gfxFont.cpp:325
12	thunderbird-bin	gfxTextRun::DrawGlyphs	gfx/thebes/src/gfxFont.cpp:1603
13	thunderbird-bin	gfxTextRun::Draw	gfx/thebes/src/gfxFont.cpp:1813
14	thunderbird-bin	nsTextFrame::DrawText	layout/generic/nsTextFrameThebes.cpp:4563
15	thunderbird-bin	nsTextFrame::PaintText	layout/generic/nsTextFrameThebes.cpp:4550
16	thunderbird-bin	nsDisplayText::Paint	layout/generic/nsTextFrameThebes.cpp:3778
17	thunderbird-bin	nsDisplayList::Paint const	layout/base/nsDisplayList.cpp:313
18	thunderbird-bin	nsLayoutUtils::PaintFrame	layout/base/nsLayoutUtils.cpp:1114
19	thunderbird-bin	nsPageFrame::PaintPageContent	layout/generic/nsPageFrame.cpp:582
20	thunderbird-bin	PaintPageContent	layout/generic/nsPageFrame.cpp:405

bp-e77b3726-51bd-4584-b7ad-8b2b82100219  v3.0  Build20091204202227
0	libPDFRIP.A.dylib	libPDFRIP.A.dylib@0x181c2	
1	libPDFRIP.A.dylib	libPDFRIP.A.dylib@0x189a5	
2	libPDFRIP.A.dylib	libPDFRIP.A.dylib@0x318c	
3	libPDFRIP.A.dylib	libPDFRIP.A.dylib@0x3db1	
4	libRIP.A.dylib	libRIP.A.dylib@0x3299f	
5	CoreGraphics	CoreGraphics@0x30401	
6	CoreGraphics	CoreGraphics@0x2fd56	
7	thunderbird-bin	_cairo_quartz_surface_show_glyphs	gfx/cairo/cairo/src/cairo-quartz-surface.c:2124
8	thunderbird-bin	_cairo_surface_show_text_glyphs	gfx/cairo/cairo/src/cairo-surface.c:2305
9	thunderbird-bin	_cairo_gstate_show_text_glyphs	gfx/cairo/cairo/src/cairo-gstate.c:1620
10	thunderbird-bin	_moz_cairo_show_glyphs	gfx/cairo/cairo/src/cairo.c:3170
11	thunderbird-bin	gfxFont::Draw	gfx/thebes/src/gfxFont.cpp:325
12	thunderbird-bin	gfxTextRun::DrawGlyphs	gfx/thebes/src/gfxFont.cpp:1603
13	thunderbird-bin	gfxTextRun::Draw	gfx/thebes/src/gfxFont.cpp:1813
14	thunderbird-bin	nsTextFrame::DrawText	layout/generic/nsTextFrameThebes.cpp:4563
15	thunderbird-bin	nsTextFrame::PaintText	layout/generic/nsTextFrameThebes.cpp:4550
16	thunderbird-bin	nsDisplayText::Paint	layout/generic/nsTextFrameThebes.cpp:3778
17	thunderbird-bin	nsDisplayList::Paint const	layout/base/nsDisplayList.cpp:313
18	thunderbird-bin	nsLayoutUtils::PaintFrame	layout/base/nsLayoutUtils.cpp:1114
19	thunderbird-bin	nsPageFrame::PaintPageContent	layout/generic/nsPageFrame.cpp:582
20	thunderbird-bin	PaintPageContent	layout/generic/nsPageFrame.cpp:405
Component: General → Graphics
Product: Thunderbird → Core
QA Contact: general → thebes
This is bug 534672; these two crash reports are from shipped-with-new-Macs builds of Mac OS X (and, at least in the 10.6.1 case, the reporter has not updated to 10.6.2 :( ).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Summary: crash [@ libPDFRIP.A.dylib@0x181c2 ] → crash [@ libPDFRIP.A.dylib@0x181c2 ] [@ layout_flush_block]
Duplicate of bug: 534672
(Assignee)

Updated

8 years ago
Crash Signature: [@ libPDFRIP.A.dylib@0x181c2 ] [@ layout_flush_block]
You need to log in before you can comment on or make changes to this bug.