ampersand in signatures is correct when sent but provides odd spacing when received

RESOLVED DUPLICATE of bug 541978

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED DUPLICATE of bug 541978
8 years ago
8 years ago

People

(Reporter: Edmund Alexander Sims, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

I was able to replicate this across a couple of the email accounts I use within Thunderbird.  Basically, I use something like "This is a Test & Example" for the signature.  When I send it, the signature looks exactly like what I wrote.  But when the message is received either by Thunderbird or even Yahoo, that signature gets turned into "This is a Test&  Example".  It seems to happen whether the signature is stored within Thunderbird or I use a text file which contains the signature.  I was not using any HTML either.  This was all plain text.  When you check your sent file, you can even see that it was sent as "This is a Test&  Example" and not "This is a Test & Example".  The bug produces a signature that seems to strip the *space* from the left side of the ampersand and puts an extra one on the right so the ampersand is smooshed up against the word on the left and has two spaces between it and the word on the right.  Help!  :)

Reproducible: Always

Steps to Reproduce:
1.  Put "This is a Test & Example" in a signature (text file or directly into Thunderbird)
2.  Send the message
3.  Check the sent file and the recipient message for evidence of the mangled signature which should look like "This is a Test&  Example"
Actual Results:  
Signature in the sent file and the recipient email looked like "This is a Test&  Example".

Expected Results:  
The signature in the sent file and the recipient email should have looked like "This is a Test & Example".
Reproduced on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.8) Gecko/20100216 Lightning/1.0b1 Thunderbird/3.0.2 ID:20100216161403 (in Safe Mode, with two different profiles). Note that the saved draft is just fine.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

8 years ago
It's an HTML to plain-text serializer issue.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541978
You need to log in before you can comment on or make changes to this bug.