Impossible to add comments if you are logged in the site

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
1/ be logged in wordpress (as an admin for me)
2/ try to add a comment

expected result:
comment added

actual result:
nothing happens on clicking the submit button. If I log out, the button works.
Now, that's funny. Is it possible to have the list of plugin installed in WP to make some local tests?
Thanks.

So, the problem is surely in the theme: same WP installation, with the default theme commenting works fine, with the website theme it doesn't.
Now, we have to understand where the problem is in the code.
Found the bug. In file comments.php line 84:

<button id="btn_commentSubmit" class="submit-comment" name="submit" type="submit" tabindex="4"><?php _e('submit','choice'); ?></button>

must be changed with:

<button id="submit" class="submit-comment" name="submit" type="submit" tabindex="4"><?php _e('submit','choice'); ?></button>

Possible explanation: WP need the id of the button to be "submit" to work properly. If you're not logged everything works because the author data (name, mail) are within the form, so the id of the button isn't important. If you're logged the author data are fetched from the database, and WP need the "submit" id to understand that it must fetch data from the database.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 5

9 years ago
The problem was in the client side validation. This was fixed by Andres Garcia.
May I ask you, just out of curiosity, which piece of code did you change? I'd love to learn something from this. Thanks!
r63266 might have some answers, but I'm not sure :)
OS: Linux → All
Hardware: x86 → All

Updated

8 years ago
Component: opentochoice.org → opentochoice.org
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.