scrolling is broken on a page with more than one scrollbar on FF 3.6

RESOLVED DUPLICATE of bug 541668

Status

()

RESOLVED DUPLICATE of bug 541668
9 years ago
3 years ago

People

(Reporter: looris, Unassigned)

Tracking

({regression})

1.9.2 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8

I have this page with two or three vertical scrollbars, created with style "max-height", contained in tables.

The expected behaviour when you use the mouse scroll wheel is that the div under the mouse scrolls.
This worked up until FF 3.5 and works on Camino and on Safari.

On FF 3.6 the rightmost div often gets stuck.

Reproducible: Always

Steps to Reproduce:
1. using FF 3.6 open page http://orkmanager.com/view/league?conference_id=1&edition=8&division=0&group=0#now
you will see two main divs, one with match listing (to the center of the page) id="sx_table", and one with the ranking (to the right of the page) id="dx_table".

2. use your scroll wheel to scroll sx_table over and over, it will work fine
3. do the same thing on dx_table, it won't. If it does work (rarely happens), goto point 2.
Actual Results:  
dx_table doesn't scroll properly

Expected Results:  
dx_table scrolls properly as everything else

Worked up until FF 3.5, works on Camino and Safari, I'm pretty sure it works almost everywhere so it's definitly a FF 3.6 bug.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100217 Namoroka/3.6.2pre

Firefox 3.5 worked indeed fine and also latest trunk shows no problem anymore.
Component: General → General
Keywords: regression, regressionwindow-wanted
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
Version: 3.6 Branch → 1.9.2 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541668
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.