Copy not saved in sent from folder (inbox) when replying to a filtered message.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: gordon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Opera/9.80 (Windows NT 5.0; U; en) Presto/2.2.15 Version/10.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

If someone replies to me personally from a mailing list I filter that message to my regular inbox. If I subsequently reply to that message from my regular inbox, changing the From: address appropriately; it won't save a copy of the sent mail in the regular inbox (which it normally would), or anywhere else. 

Reproducible: Always

Steps to Reproduce:
1.Create a filter in an account normally reserved for a Yahoo group where the reply to is set to the Yahoo group. Filter: To - Doesn't contain - *@yahoogroups.com, Move message to - some inbox. 
2.Get someone to reply to you personally (off list) from the group. 
3.Right click the message and 'Reply to Sender Only'. Make sure the account "Place replies in the folder of the message being replied to" is checked. 
4.Change the From: field to the one appropriate for the inbox it's in. 
5.Send the mail. 
Actual Results:  
No copy of the mail is saved - anywhere.

Expected Results:  
A copy of the sent mail should have been placed in the folder of the message being replied to. 

Default theme used.
Execute "Send Later" instead of "Send", go Outbox of "Local Folders", and view/message source of mail to be sent. Next heaers are for will-be-sent mail.
> FCC: mailbox://a@a.a.a/Sent
> X-Identity-Key: id2
> X-Account-Key: account3
> X-Mozilla-Draft-Info: internal/draft; vcard=0; receipt=0; DSN=0; uuencode=0
mail address in From:, "FCC: mailbox:...", idX of X-Identity-Key:, accountN in X-Account-Key:, are consistent and ones you expected? (see pres.js content of Config Editor list for account/identity, FCC folder settings)

What folder do you set as "folder to save copy of sent mail" at identitiy setting for the mail address you used in From:? 

View Message Source of original mail to be replied.
  What is written in X-Account-Key: header?
  In which account's Inbox is the mail held?
(Reporter)

Comment 2

9 years ago
Mail address in From = gordon@mgcsoft.com

user_pref("mail.identity.id1.fcc_folder", "mailbox://gordon%40mgcsoft.com@mgcsoft.com/Inbox");

Local directory: F:\t-bird-mail\mgcsoft.com

idX of X-Identity-Key not sure what you mean here but it's id1 and the first one in the account list. 
 
id1 = account2 not sure what to expect but that's what it is.
 
Hope I've answered your questions. Not quite sure what I'm looking at in prefs.js. 

Gordon

Comment 3

7 years ago
You are asked to look into the composed message source (see the menu) to what the headers X-Identity-Key, X-Account-Key, X-Mozilla-Draft-Info are set.
Ping ?

Comment 5

7 years ago
Gordon seems to be gone
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.