Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Paula K., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Media Center PC 5.0; SLCC1; InfoPath.1; Tablet PC 2.0; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
Build Identifier: v.3.6, released January 21st, 2010

Today I got my computer back from the shop after they reinstalled the boot sector of my C: drive to cure boot hang-up (I'm not a computer wonk, I just know enough words to be dangerous!).  When I opened Firefox it generated this error message:  Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]

I closed Firefox and tried it again and I got the same message.  My roomie has v 3.6 on her 'pooter and it starts with no errors every time.

I deinstalled Firefox using the utility that Windows 7 provides, then I downloaded it from the www.mozilla.org website and I still get the same failure message.  My roomie's system works just fine.

I have no idea what this failure affects.  I hope that it's not security-related.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Failure message appears
3.Click OK in failure message box and continue to tentatively use Firefox, not knowing if this is a security-related issue
Actual Results:  
Exactly as described above every time

Expected Results:  
That after deinstall/reinstall the failure message would go away

I have no idea how serious this bug is except to say that if I don't click OK on the message box, Firefox would stop working.  ***I do not know if this is a security issue.  A perception of greater security is why I use Firefox.

Severity?  I don't know.  

Thanks for hearing me out.

Comment 1

8 years ago
Hi, this message is probably benign and is likely caused by an extension.

Try getting help from http://support.mozilla.com/ , first try http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes and if it doesn't help, try asking a question in the forum.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.