Reference to static function in function templates not allowed with Sun Studio compiler

RESOLVED FIXED in mozilla1.9.3a3

Status

()

Core
Build Config
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Ginn Chen, Assigned: Ginn Chen)

Tracking

Trunk
mozilla1.9.3a3
x86
OpenSolaris
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 56: Error: Reference to static mozilla::storage::sqlite3_T_null(sqlite3_context*) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 70: Error: Reference to static mozilla::storage::sqlite3_T_int(sqlite3_context*, int) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 80: Error: Reference to static mozilla::storage::sqlite3_T_int64(sqlite3_context*, long long) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 88: Error: Reference to static mozilla::storage::sqlite3_T_double(sqlite3_context*, double) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 95: Error: Reference to static mozilla::storage::sqlite3_T_int(sqlite3_context*, int) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 109: Error: Reference to static mozilla::storage::sqlite3_T_text(sqlite3_context*, const nsCString&) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 123: Error: Reference to static mozilla::storage::sqlite3_T_text16(sqlite3_context*, const nsString&) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 128: Error: Reference to static mozilla::storage::sqlite3_T_null(sqlite3_context*) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/slave/ffslave/mozilla-central-solaris-sparc/build/storage/src/variantToSQLiteT_impl.h", line 149: Error: Reference to static mozilla::storage::sqlite3_T_blob(sqlite3_context*, const void*, int) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
gmake[5]: *** [mozStorageConnection.o] Error 9
(Assignee)

Comment 1

8 years ago
Created attachment 428663 [details] [diff] [review]
patch
Assignee: nobody → ginn.chen
Status: NEW → ASSIGNED
Attachment #428663 - Flags: review?(benjamin)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 548799

Updated

8 years ago
Attachment #428663 - Flags: review?(benjamin) → review+
(Assignee)

Comment 3

8 years ago
http://hg.mozilla.org/mozilla-central/rev/254cef95d664
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

8 years ago
Comment on attachment 428663 [details] [diff] [review]
patch

Required for 1.9.2 branch.
Attachment #428663 - Flags: approval1.9.2.3?
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.3a3
Created attachment 434299 [details] [diff] [review]
(Bv1-CC) Copy it to comm-central, (m-1.9.2+)
[Superseded by bug 574639]
Attachment #434299 - Flags: review?(bugspam.Callek)
Comment on attachment 434299 [details] [diff] [review]
(Bv1-CC) Copy it to comm-central, (m-1.9.2+)
[Superseded by bug 574639]

caveat; do not land until after a 1.9.2 landing; rs+ if you want to ifdef this for 1.9.2 and land now, and rs+ for removing THAT ifdef once it does land; your choice.
Attachment #434299 - Flags: review?(bugspam.Callek) → review+
Whiteboard: [ToDo: land Bv1-CC after m-1.9.2 landing]
Comment on attachment 428663 [details] [diff] [review]
patch

Clearing old approval requests now that 1.9.2.4 has shipped. If you believe this patch is still necessary on the 1.9.2 branch please re-request approval along with a risk/benefit analysis explaining why we need it.
Attachment #428663 - Flags: approval1.9.2.4?
Depends on: 574639
Attachment #434299 - Attachment description: (Bv1-CC) Copy it to comm-central, (m-1.9.2+) → (Bv1-CC) Copy it to comm-central, (m-1.9.2+) [Superseded by bug 574639]
Attachment #434299 - Attachment is obsolete: true
Whiteboard: [ToDo: land Bv1-CC after m-1.9.2 landing]
You need to log in before you can comment on or make changes to this bug.