crash [@ nsHTMLReflowState::CalcLineHeight(nsStyleContext*, int)] [Mac]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: mike001, Unassigned)

Tracking

({crash})

1.9.1 Branch
All
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
crash [@ nsHTMLReflowState::CalcLineHeight(nsStyleContext*, int) ]

#24 crash for Macs, not in top 100 overall (total 67, all Mac, Jan27-Feb24)
All occurrences in v3.0.1:
  21 MacOS 10.4.11 (8S165)
  15 MacOS 10.4.11 (8S2167)
  27 MacOS 10.6.2 (10C540)
  4 MacOS 10.6.2 (10C2234)
(no occurrences for 1.9.2 or 1.9.3 branches)

Lots of "HTMLReflow" crash bugs, but none exactly like this, nor any that seem obviously similar.  I do find it curious that all crashes are limited to 3.0.1 (searched all branches), and there are no 10.5.x crashes.

No user comments.

bp-6135ca05-e1f2-45ed-bd48-a22cc2100224  v3.0.1  Build20100111130305
0	thunderbird-bin	nsHTMLReflowState::CalcLineHeight	layout/generic/nsHTMLReflowState.cpp:2037
1	thunderbird-bin	nsHTMLReflowState::CalcLineHeight const	layout/generic/nsHTMLReflowState.cpp:2097
2	thunderbird-bin	thunderbird-bin@0x2f35e8	
3	thunderbird-bin	nsBlockFrame::Reflow	layout/generic/nsBlockFrame.cpp:927
4	thunderbird-bin	nsContainerFrame::ReflowChild	layout/generic/nsContainerFrame.cpp:821
5	thunderbird-bin	CanvasFrame::Reflow	layout/generic/nsHTMLFrame.cpp:669
6	thunderbird-bin	nsContainerFrame::ReflowChild	layout/generic/nsContainerFrame.cpp:821
7	thunderbird-bin	nsHTMLScrollFrame::ReflowScrolledFrame	layout/generic/nsGfxScrollFrame.cpp:528
8	thunderbird-bin	nsHTMLScrollFrame::ReflowContents	layout/generic/nsGfxScrollFrame.cpp:622
9	thunderbird-bin	nsHTMLScrollFrame::Reflow	layout/generic/nsGfxScrollFrame.cpp:823
10	thunderbird-bin	nsContainerFrame::ReflowChild	layout/generic/nsContainerFrame.cpp:821
11	thunderbird-bin	ViewportFrame::Reflow	layout/generic/nsViewportFrame.cpp:282
12	thunderbird-bin	PresShell::DoReflow	layout/base/nsPresShell.cpp:6717
13	thunderbird-bin	PresShell::ProcessReflowCommands	layout/base/nsPresShell.cpp:6823
14	thunderbird-bin	PresShell::DoFlushPendingNotifications	layout/base/nsPresShell.cpp:4870
15	thunderbird-bin	PresShell::ReflowEvent::Run	layout/base/nsPresShell.cpp:6594
16	libxpcom_core.dylib	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:521
17	libxpcom_core.dylib	NS_ProcessPendingEvents_P	 nsThreadUtils.cpp:200
18	thunderbird-bin	nsBaseAppShell::NativeEventCallback	widget/src/xpwidgets/nsBaseAppShell.cpp:121
19	thunderbird-bin	nsAppShell::ProcessGeckoEvents	widget/src/cocoa/nsAppShell.mm:406

bp-0f291d04-1f54-426a-88d9-49e642100223  v3.0.1  Build20100111130305
0	thunderbird-bin	nsHTMLReflowState::CalcLineHeight	layout/generic/nsHTMLReflowState.cpp:2037
1	thunderbird-bin	nsHTMLReflowState::CalcLineHeight const	layout/generic/nsHTMLReflowState.cpp:2097
2	thunderbird-bin	thunderbird-bin@0x2f35e8	
3	thunderbird-bin	nsBlockFrame::Reflow	layout/generic/nsBlockFrame.cpp:927
4	thunderbird-bin	nsBlockReflowContext::ReflowBlock	layout/generic/nsBlockReflowContext.cpp:310
5	thunderbird-bin	nsBlockFrame::ReflowBlockFrame	layout/generic/nsBlockFrame.cpp:3012
6	thunderbird-bin	nsBlockFrame::ReflowLine	layout/generic/nsBlockFrame.cpp:2283
7	thunderbird-bin	nsBlockFrame::ReflowDirtyLines	layout/generic/nsBlockFrame.cpp:1911
8	thunderbird-bin	nsBlockFrame::Reflow	layout/generic/nsBlockFrame.cpp:955
9	thunderbird-bin	nsBlockReflowContext::ReflowBlock	layout/generic/nsBlockReflowContext.cpp:310
10	thunderbird-bin	nsBlockFrame::ReflowBlockFrame	layout/generic/nsBlockFrame.cpp:3012
11	thunderbird-bin	nsBlockFrame::ReflowLine	layout/generic/nsBlockFrame.cpp:2283
12	thunderbird-bin	nsBlockFrame::ReflowDirtyLines	layout/generic/nsBlockFrame.cpp:1911
13	thunderbird-bin	nsBlockFrame::Reflow	layout/generic/nsBlockFrame.cpp:955
14	thunderbird-bin	nsContainerFrame::ReflowChild	layout/generic/nsContainerFrame.cpp:821
15	thunderbird-bin	CanvasFrame::Reflow	layout/generic/nsHTMLFrame.cpp:669
16	thunderbird-bin	nsContainerFrame::ReflowChild	layout/generic/nsContainerFrame.cpp:821
17	thunderbird-bin	nsHTMLScrollFrame::ReflowScrolledFrame	layout/generic/nsGfxScrollFrame.cpp:528
18	thunderbird-bin	nsHTMLScrollFrame::ReflowContents	layout/generic/nsGfxScrollFrame.cpp:622
19	thunderbird-bin	nsHTMLScrollFrame::Reflow	layout/generic/nsGfxScrollFrame.cpp:823
20	thunderbird-bin	nsContainerFrame::ReflowChild	layout/generic/nsContainerFrame.cpp:821
Component: General → Layout
Product: Thunderbird → Core
QA Contact: general → layout
(Reporter)

Updated

9 years ago
Severity: normal → critical
Looks like a possibly-bogus aFontMetrics pointer, given the crash address and the crash location.

On the other hand, I'm not sure how nsLayoutUtils::GetFontMetricsForStyleContext can produce such a bogus font metrics object...
Version: unspecified → 1.9.1 Branch
#165 crash for 3.0.5, but no crashes found for v3.1
Status: NEW → UNCONFIRMED
Ever confirmed: false
Summary: crash [@ nsHTMLReflowState::CalcLineHeight(nsStyleContext*, int) ] → crash [@ nsHTMLReflowState::CalcLineHeight(nsStyleContext*, int) ] [Mac
... so => WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Summary: crash [@ nsHTMLReflowState::CalcLineHeight(nsStyleContext*, int) ] [Mac → crash [@ nsHTMLReflowState::CalcLineHeight(nsStyleContext*, int)] [Mac]
and also gone from firefox as of FF 3.6
Crash Signature: [@ nsHTMLReflowState::CalcLineHeight(nsStyleContext*, int)]
You need to log in before you can comment on or make changes to this bug.