Closed Bug 548344 Opened 12 years ago Closed 11 years ago

[OOPP] plugin crash UI shown in chrome if using Bing toolbar

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jbecerra, Unassigned)

References

Details

(Whiteboard: [OOPPTestday] [bugday0601])

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100224 Minefield/3.7a2pre (.NET CLR 3.5.30729)
Silverlight: 3.0.50106.0
Flash: 10.0.32.18
Bing Bar: 5.0.1363.0

I was following the steps to reproduce bug 545686 when I noticed that if you end the mozilla-runtime process, and you have the Bing Bar installed, you will get the plugin crash UI shown in the toolbar.

Steps:
1. Open http://www.megavideo.com/?v=NKCUTMML
2. Try to play a video
3. End one or two of the mozilla-runtime processes running using the taskmanager

Expected: Page showing the new plugin crash UI

Actual: Part of the plugin crash UI is show in the toolbar above the tab strip.
I have seen this bug while testing on the lab on Windows Vista trunk.
I'm guessing the Bing toolbar is using Silverlight, and so killing that mozilla-runtime results in this?

Somewhat odd that we're still showing the UI even though it's too small... Oh, something probably fails because it's in chrome so it can't figure out how to do the notification bar. Errors in the error console?
The Bing toolbar uses Silverlight. Killing that mozilla-runtime results in this, but no errors are shown in the console. The Bing bar installs itself such that launching Minefield with any new profile will get it.
This doesn't seem like a big deal to me... is the plugin-crashed UI the same size as the bing toolbar normally is? obviously displaying the plugin-crashed UI here isn't ideal because the user can't do anything about it (other than close and re-open the browser window), but plugins in chrome are unusual.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100601 BRI/1 Minefield/3.7a5pre

Obviously, this is still an issue.  The issue here is that the Plugin Crash UI does not discriminate against plugins-in-chrome vs plugins-in-content.  We should really have a "better" experience for plugins-in-chrome.

Suggest hijacking this bug to take care of that?
Whiteboard: [OOPPTestday] → [OOPPTestday] [bugday0601]
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.