nsXULElement::Normalize not implemented

RESOLVED WORKSFORME

Status

Core Graveyard
Java APIs for DOM
P3
normal
RESOLVED WORKSFORME
18 years ago
6 years ago

People

(Reporter: Arthur Barrett, Assigned: Ashu Kulkarni)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
In the C++ class mozilla/rdf/content/src/nsXULElement.cpp the Normalize method 
is implemented to return an error, NOTIMPLEMENTED.

Other C++ classes that do not implement this method return NS_OK.
e.g.:
http://lxr.mozilla.org/seamonkey/source/layout/base/src/nsGenericDOMDataNode.cpp
#229

When the Java to DOM is activated to register a Document load listener (    
DOMAccessor.addDocumentLoadListener((DocumentLoadListener)this);) this NOT 
IMPLEMENTED assertion is raised.

Altering the class in question to return NS_OK appears to work with no ill 
effects.

If Normalize is supposed to return NS_OK, it would be highly desirable to fix 
this before M18 branch.

Comment 1

18 years ago
*** Bug 54839 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

18 years ago
Created attachment 15936 [details] [diff] [review]
Suggested patch
(Reporter)

Comment 3

18 years ago
Created attachment 15937 [details] [diff] [review]
Suggested patch

Comment 4

18 years ago
Thanks Arthur for bringing this bug to my attention... this bug was not showing 
up in the query page because of its unconfirmed state... it was completely off 
the radar. I will change the state to New and cc Ed, who's leading the blackwood 
work.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
reassigning to denis sharypov, the real owner of java dom
Assignee: akhil.arora → sdv

Comment 6

18 years ago
hopefully george will try to find a new owner for this bug
Assignee: sdv → drapeau

Comment 7

17 years ago
Ashu is taking ownership of JavaDOM bugs.  Re-assigning to him.
Assignee: drapeau → ashuk
(Assignee)

Comment 8

17 years ago
Would changing the nsXULElement::Normailze() to return NS_OK cause any problems 
to objects making calls to this function? This is a change in the Content 
module and so I'd like feedback from the module owner. adding hyatt to the cc 
list.

http://lxr.mozilla.org/mozilla/source/content/xul/content/src/nsXULElement.cpp#1
324

hyatt, pls see the patch and let me know if this is acceptable.

-------------PATCH------------

Index: nsXULElement.cpp
===================================================================
RCS file: /cvsroot/mozilla/content/xul/content/src/nsXULElement.cpp,v
retrieving revision 1.332
diff -u -r1.332 nsXULElement.cpp
--- nsXULElement.cpp	2001/04/04 04:30:03	1.332
+++ nsXULElement.cpp	2001/04/12 22:58:50
@@ -1323,8 +1323,7 @@
 NS_IMETHODIMP
 nsXULElement::Normalize()
 {
-  NS_NOTYETIMPLEMENTED("write me!");
-  return NS_ERROR_NOT_IMPLEMENTED;
+    return NS_OK;
 }

-----------------------------

thnx
_Ashu
Status: NEW → ASSIGNED

Comment 9

17 years ago
Changing QA contact
QA Contact: rajendra.pallath → avm

Comment 10

16 years ago
A DOM question:
In javascript, I tried 
  node.normalize()
and I got "undefined". Is this related to this bug?

Comment 11

12 years ago
Normalize is implemented, I think, since nsXULElement was made to extend from nsGenericElement (bug 198533).
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Summary: mozilla/rdf/content/src/nsXULElement.cpp Normalize not implemented → nsXULElement::Normalize not implemented
Component: Java APIs for DOM → Java APIs for DOM
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.