change outgoing email sender needs to be a little more official

RESOLVED DUPLICATE of bug 549377

Status

--
minor
RESOLVED DUPLICATE of bug 549377
9 years ago
4 years ago

People

(Reporter: scrivi, Unassigned)

Tracking

({drupal-admin-fixable})

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; it; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: alpha

as of now the email sender for password reset is not an "official" drumbeat address.
To avoid spam filtering and a more official image with users, I think it's better to have something like "password_recover@drumbeat.org" or whatever works with spam filtering

Reproducible: Always

Steps to Reproduce:
1. you forget your password ;P
2. you ask for a reset
3. you receive the email

Comment 1

9 years ago
agree its sending me matt@ on sign up and new password

can be changed here admin/settings/site-information
This will be much easier when we have control of the domain's DNS directly (bug 548542) and can set up MX records.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

9 years ago
Yep sounds good. Let's switch to "info@drumbeat.org" once we have control of DNS.
Summary: email sender needs to be a little more official → change outgoing email sender needs to be a little more official

Comment 4

9 years ago
Just a friendly poke to see if there are any developments.

Best,
Paul Booker
Appcoast

Comment 5

9 years ago
Paul: thanks for the reminder! Let's switch to:
drumbeat@mozillafoundation.org

Can you do that?

Comment 6

9 years ago
    @Matt @Gerv

    Ultimately the simple change has to be done @ 
    https://www.drumbeat.org/admin/settings/site-information

    Thinking carefully about procedure i guess i can resolve this independently as
    follows ..

    1. Make the change on Trellon development / Confirm working
    2. Make the change on Mozilla stage / Confirm working
    3  Make the change on Mozilla production / Confirm working
    4. Resolve the bugs as RESOLVED / FIXED
    5. Another contributor verifies that the bug is fixed and marks as RESOLVED /
    CLOSED

    Does that sound ok ?

    Best,
    Paul Booker
    Appcoast
Changing email config is trickier than other config changes because email works differently on all three systems. So, for example, a message sent From "drumbeat@mozillafoundation.org" by Trellon's server may get spam-binned because the server is not a permitted sender for the domain "mozillafoundation.org", whereas if we send it from the production server, it uses the Mozilla SMTP servers as a smarthost (I think) and so it'll work fine.

Matt: why do you particularly want "drumbeat@mozillafoundation.org" as the From address for password reset emails? Normally, I would have thought such emails would have a "no-reply@" type address. And I'd sort of expect it to be @drumbeat.org too...

Unless this is urgent for some reason, we should wait until the domain is using our DNS servers, and we have MX records set up correctly for drumbeat.org allowing mail sending and delivery, and then create an alias no-reply@drumbeat.org which accepts all mail and pipes it to /dev/null, and then use that.

Gerv

Comment 8

9 years ago
@Gerv

I agree however i think Drupal also uses the email address given @ admin/settings/site-information to email posts made from the contact page and that other contributed module may do likewise (I'll investigate) 

Best,
Paul Booker
Appcoast

Updated

9 years ago
Assignee: nobody → paulbooker

Comment 9

9 years ago
@Gerv

It looks as though the email address specified @ admin/settings/site-information is used for "to" ,  "from" and "reply to" email addresses

However it may be possible to get  no-reply@drumbeat.org and contact email addresses with the help of actions, triggers and rules.modules (not sure) 

Best,
Paul Booker
Appcoast
Assignee: paulbooker → nobody
OK, if it's simpler, let's go with info@drumbeat.org or something neutrally-named, and make sure someone's on the other end of it.

Gerv

Comment 11

9 years ago
@Gerv

Sounds good :-)

@Matt

#What shall we use for the email address ?
 (another suggestion for consideration .. team@drumbeat.org )

#Shall we setup this email address as a mail group ? 
 (If we go this route feel free to assign my email address paulbooker@appcoast to the mail group so that i can help out there :-) )  


Best, 
Paul Booker
Appcoast

Updated

9 years ago
Keywords: drupal-admin-fixable

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 549377
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.