Closed Bug 548468 Opened 11 years ago Closed 7 years ago

3.0 fetches all newsgroup headers for ALL groups asynchronously; TB 2 fetched as needed (visited, read)

Categories

(MailNews Core :: Networking: NNTP, defect)

1.9.1 Branch
All
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Mly, Unassigned)

Details

(Keywords: regression, Whiteboard: [wontfix?])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 3.0.1 Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

In Thunderbird 3, opening a newsgroup account seems to provoke some
asynchronous background task to downloading all the headers (XREF) for
all of the newsgroups subscribed to.

In Thunderbird 2, a much more reasonable thing was done: headers would
only be fetched as individual newsgroups were read.

The current behaviour is wrong because
(a) it chews up network bandwidth and (possibly administratively limited) server resources and
(b) it triggers repeated and EXTREMELY IRRITATING mail.server.server*.max_articles warning dialogs.


Reproducible: Always

Steps to Reproduce:
1. Set the appropriate mail.news.server*.max_articles to a finite value
   (AKA Account "Settings..." / "Server Settings" / "Ask me before downloading more than" ___ "message")
2. Open a news server with any single group that has not been read in some time.
3. Open a newsgroup that has been read.

Actual Results:  
I should only be queried about downloading large numbers of headers for the newsgroup I am reading.

Headers for other newsgroups should not be downloaded at all until requested.

Expected Results:  
Every single group with more than 1000 (test value for the max_articles user configuration parameter) pops up a dialog asking
"There are %d new message headers for download for this newsgroup .."
EVEN THOUGH I AM NOT READING THOSE GROUPS.


Another TB 3 regression.  Numerous new bugs, no new features for me so far.
The irritating pop-up dialog is asking about a newsgroup I AM NOT READING and may not choose to read for weeks.

The same irritating pop-up will be repeated (this is just one of several successive ones that pop up in sequence) for each newsgroup with more than the threshold number of uncached headers.
Are your news servers set up to check for new messages on startup/every n minutes?
(In reply to comment #2)
> Are your news servers set up to check for new messages on startup/every n
> minutes?

No.

And in any case, this is a regression from TB2, since I never changed anything
other than installing a newer Thunderbird executable.



FYI here's everything from prefs.js for my example news account:

user_pref("mail.account.account3.server", "server3");
user_pref("mail.server.server3.ageLimit", 30);
user_pref("mail.server.server3.charset", "ISO-8859-1");
user_pref("mail.server.server3.daysToKeepBodies", 30);
user_pref("mail.server.server3.daysToKeepHdrs", 30);
user_pref("mail.server.server3.directory", ...);
user_pref("mail.server.server3.directory-rel", "[ProfD]News/news.sonic.net");
user_pref("mail.server.server3.hostname", "news.sonic.net");
user_pref("mail.server.server3.max_articles", 1000);
user_pref("mail.server.server3.max_cached_connections", 2);
user_pref("mail.server.server3.name", "news.sonic.net");
user_pref("mail.server.server3.newsrc.file", ...);
user_pref("mail.server.server3.newsrc.file-rel", "[ProfD]News/news.sonic.net.rc\
");
user_pref("mail.server.server3.numHdrsToKeep", 30);
user_pref("mail.server.server3.type", "nntp");


I'm attaching a screen shot of the account config UI also.
Unsolicited background caching tasks should *never* pop up UI dialogs.
If they fail, they fail, and a cache isn't pre-filled.
That's nothing the user either needs to know about or should be FORCED to care about.
Joshua do we need protocol logs ?
Keywords: regression
(In reply to comment #0)
> In Thunderbird 3, opening a newsgroup account seems to provoke some
> asynchronous background task to downloading all the headers (XREF) for
> all of the newsgroups subscribed to.

This is normal behavior since Bugfix (attachment 402483 [details] [diff] [review]) of Bug 311774.

> I should only be queried about downloading large numbers of headers for the
> newsgroup I am reading.
> 
> Headers for other newsgroups should not be downloaded at all until requested.

If this is what you blame, set Config: "news.update_unread_on_expand" to false. But you won't get any unread count until you enter the group.

HTH
joshua, is this wontfix, or WFM given the available perf setting?


(In reply to Alfred Peters from comment #6)
> > I should only be queried about downloading large numbers of headers for the
> > newsgroup I am reading.
> > 
> > Headers for other newsgroups should not be downloaded at all until requested.
> 
> If this is what you blame, set Config: "news.update_unread_on_expand" to
> false. But you won't get any unread count until you enter the group.
> 
> HTH
Component: General → Networking: NNTP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.nntp
Whiteboard: [wontfix?]
Target Milestone: --- → Thunderbird 3
Target Milestone: Thunderbird 3 → ---
Version: unspecified → 1.9.1 Branch
(In reply to Wayne Mery (:wsmwk) from comment #7)
> joshua, is this wontfix, or WFM given the available perf setting?
> 
> 
> (In reply to Alfred Peters from comment #6)
> > > I should only be queried about downloading large numbers of headers for the
> > > newsgroup I am reading.
> > > 
> > > Headers for other newsgroups should not be downloaded at all until requested.
> > 
> > If this is what you blame, set Config: "news.update_unread_on_expand" to
> > false. But you won't get any unread count until you enter the group.
> > 
> > HTH
Flags: needinfo?(Pidgeot18)
The news.update_unread_on_expand should be sufficient, I think.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(Pidgeot18)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.