Button in in rowspan table cell not clickable

RESOLVED DUPLICATE of bug 541668

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 541668
8 years ago
8 years ago

People

(Reporter: Quest, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (Windows NT 5.1; U; en) Presto/2.2.15 Version/10.00
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Any part of a button that is not inside the cell area of the first row is not clickable if the button has style "display: block".

Reproducible: Always

Steps to Reproduce:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <body>
    <table>
      <tbody>
        <tr>
          <td rowspan="2" valign="bottom">
            <form method="post" action="/fleet/pages/booking/bookingInfo.seam.htm">
              <input value="Button" style="display: block" type="submit"/>
            </form>
          </td>
          <td>
            <span>Foo</span>
          </td>
        </tr>
        <tr>
          <td>
            <span>Bar</span>
          </td>
        </tr>
      </tbody>
    </table>
  </body>
</html>



Sticking buttons in a table cell is a typical example of using tables for layout. We may frown upon this practice, but since this problem was introduced very recently, it may break quite a few web pages out there. It appears that for example Firefox 3.5.8 does not exhibit this problem. Therefore, I would argue fixing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Layout: Form Controls → Layout: Tables
QA Contact: layout.form-controls → layout.tables
Resolution: --- → DUPLICATE
Duplicate of bug: 541668
You need to log in before you can comment on or make changes to this bug.