Changing identity duplicates signature

RESOLVED DUPLICATE of bug 218346

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 218346
8 years ago
8 years ago

People

(Reporter: Niels Baggesen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da-DK; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9.2.2pre) Gecko/20100223 Lightning/1.0b2pre Lanikai/3.1b1pre

If changing identity while composing a mail, the signature from the new identity is added, which is good, but the signature from the old identity is not removed.

This problem did not exist with Thunderbird 2.0.0.x, but appeared when I upgraded to 3.0, and is still there now with 3.1b1pre.

I compose in plain text.

Reproducible: Always

Steps to Reproduce:
1. Compose new mail (or reply, or ...)
2. Change sending identity
3. You now have an extra signature at the bottom of the mail


Expected Results:  
The original signature should have been removed.
When you says "identity" you means to account?
Anyway I can't reproduce here on 

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2pre) Gecko/20100225 Lightning/1.0b2pre Lanikai/3.1b1pre ID:20100225032808

Could you try to start TB in safe-mode (see here how-to start TB in safe-mode http://kb.mozillazine.org/Safe_mode )
(Reporter)

Comment 2

8 years ago
No, I mean identities. I have several accounts, and some of them have several identities.

Running in safe-mode makes no difference.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 218346
(Reporter)

Comment 4

8 years ago
I have signature below quoted text, and it has worked for me all the time until I started using thunderbird 3.
This is a new bug.

Comment 5

8 years ago
I confirm the bug.
Thunderbird 3.0.4
I see the "--" -sign is not there either.
I have signature above quoted text.
You need to log in before you can comment on or make changes to this bug.