Top row of a table disappears when I hover mouse pointer over a "submit"-type button in that row

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
P3
normal
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Jerry Peek, Assigned: Kevin McCluskey (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; m17) Gecko/20000807
BuildID:    2000080712

When I bring this page up, it looks correct at first... like it does on Netscape
4.75.  But, as soon as I move the mouse over the "Delete" button in the "Saved
Searches" row, that row of the table disappears right away and the page redraws.

You can see this by looking at window dumps I've put on my website.
http://www.jpeek.com/~jpeek/tmp/mozilla-before.png shows the page before I touch
the "Delete" button with my mouse.
http://www.jpeek.com/~jpeek/tmp/mozilla-after.png shows the page after.

Reproducible: Always
Steps to Reproduce:
1. Try the URL above, then move the mouse over the "Delete" button in the "Saved
Searches" area and watch that top row of the table disappear.  If that doesn't
work, try these steps:
2. Go to http://www.clicktv.com/
3. In the "member log-in" area, type username mozillatest and password justatest
. Click "GO!". (I made a special account so you could play around without
accessing my account.  I hope it has the same problem for you that my account
does for me!)
4. A channel lineup page should appear.  Click the "search" icon in the top
right corner.
5. A "search tv listings" page should appear.  Click the "Movie" link in the top
of the area with the drop-down menus and etc. Then QUICKLY move the mouse to the
lower-right corner of the window before the next page appears.
6. (I added a saved search for mozillatest that works like the one on my account
does.)  The next page (like the mozilla-before.png file on my website; see
above) should show a "Saved Searches" row at the top of the area with "Day",
"Time", etc.
7. Move the mouse on top of the "Delete" button in this "Saved Searches" area...
you don't need to click, just hover the pointer over the button.


Actual Results:  The top row of the table ("Saved Searches") disappears and the
window redraws (to look like the mozilla-after.png file on my website; see above).


Expected Results:  The top row of the table ("Saved Searches") should stay where
it is; the window shouldn't redraw.  It should keep looking like the
mozilla-before.png file on my website (This is how it works on Netscape 4.75.)


I'm using Gnome 1.1 and Enlightenment... though I don't think this should
matter?  Netscape 4.75 works fine with the same page under the same environment.

If you can grab those PNG files from my website and archive them somewhere at
mozilla.org, that would be great; I'd like to clean up my server filesystem when
I can.

The error seems to be in the part of the search.asp page shown below (copied
from my account, not the mozillatest account; I've deleted the userids and
etc.).  The ^M's are the way that vi shows the file's embedded carriage returns.
 The first line below is line 532 of the 804 lines in the search.asp file:

<!--- Begin Movie Search Form --->^M
<TABLE>^M
      <TR>^M
         <TD><!--^M
UserSearchOptions :  Module^M
  Users admin side of the saved searches.^M
Receives :^M
  act - current action of the user^M
  sform - the search form user is coming from^M
  SavedID - the ID of the Saved Search^M
  SearchName - the Name of the Saved Search^M
Returns :^M
-->^M
^M
^M
^M
  <!--- Get user stored searches --->^M
^M
  ^M
    <TABLE WIDTH="500">^M
      <TR>^M
        <TD>^M
          <FONT class="SearchSavedFormFont">Saved Searches</FONT>^M
        </TD>^M
      </TR>^M
      <TR> ^M
        <form method="get" action="search.asp">^M
        <input type="hidden" name="sform" value="3"><input type="hidden" name="p
rofileID" value="XXXX"><input type="hidden" name="WSN" value="WSERVER
21"><input type="hidden" name="UserID" value="XXXX">^M
        <TD VALIGN=top>^M
          <input type="hidden" name="SavedType" value="2">^M
          <SELECT NAME="SavedID">^M
          <OPTION VALUE="2277">Movies, 3star plus^M
          </SELECT> <INPUT TYPE=submit NAME=act VALUE="Edit"><INPUT TYPE=submit
NAME=act VALUE="Perform"><INPUT TYPE=submit NAME=act VALUE="Delete">^M
          </form>^M
        </TD>^M
      </TR>^M
^M
    <!--- Start the form for posting a new search --->^M
    <form method="get" action="search.asp">^M
    <input type="hidden" name="sform" value="3"><input type="hidden" name="profi
leID" value="XXXX"><input type="hidden" name="WSN" value="WSERVER21">
<input type="hidden" name="UserID" value="XXXX">^M

Comment 1

17 years ago
After such a good report i'm almost sorry to say i can't reproduce this bug.
Testing both the direct link and then all steps as described: No button vanish
on mouseover with build ID 2000-100106 linux.

The build you use seems to be rather old now. Whatever this was seems to have
been fixed. Can you try with a more recent build please?
(Reporter)

Comment 2

17 years ago
I just got build 2000100521 and the bug isn't there anymore.

Comment 3

17 years ago
WFM, based on reporters comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.