crash [@ TNode::IsContainer() const ] attachment

RESOLVED INVALID

Status

()

Core
Widget: Cocoa
--
critical
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: Michael A. Pasek, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rare][tbird crash], crash signature)

(Reporter)

Description

8 years ago
crash [@ TNode::IsContainer() const ] attachment

#43 [review] in 3.0.1 Top Mac crashes (1 week), not in top 100 overall
  (total 31, all Mac, Jan29-Feb24)

3.0 - 2 occurrences, MacOS 10.6.2 (10C540)
3.0.1 - 27 occurrences:
  2 MacOS 10.6.0 (10A432)
  25 MacOS 10.6.2 (10C540)
3.0.2 - 2 occurrences, MacOS 10.6.2 (10C540)

Looks to be limited to 10.6.x.

bp-a5a4bc20-3c81-445a-bffa-07fe72100224  v3.0.1  Build20100111130305
comment: [Danish] save an attachment
0	DesktopServicesPriv	TNode::IsContainer const	
1	DesktopServicesPriv	TNode::SetForceSync	
2	DesktopServicesPriv	TNode::FNNotificationHook	
3	CoreFoundation	__CFXNotificationHandleMessage	
4	CoreFoundation	__CFXNotificationReceiveFromServer	
5	CoreFoundation	__CFMachPortPerform	
6	CoreFoundation	__CFRunLoopRun	
7	CoreFoundation	CFRunLoopRunSpecific	
8	CoreFoundation	CFRunLoopRunInMode	
9	HIToolbox	RunCurrentEventLoopInMode	
10	HIToolbox	ReceiveNextEventCommon	
11	HIToolbox	BlockUntilNextEventMatchingListInMode	
12	AppKit	_DPSNextEvent	
13	AppKit	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]	
14	AppKit	-[NSApplication _realDoModalLoop:peek:]	
15	AppKit	-[NSApplication runModalForWindow:]	
16	AppKit	-[NSSavePanel runModal]	
17	thunderbird-bin	nsFilePicker::GetLocalFolder	widget/src/cocoa/nsFilePicker.mm:319
18	thunderbird-bin	nsFilePicker::Show	widget/src/cocoa/nsFilePicker.mm:213
19	thunderbird-bin	nsMessenger::SaveAllAttachments	mailnews/base/src/nsMessenger.cpp:940
20	thunderbird-bin	nsMessenger::SaveAllAttachments	mailnews/base/src/nsMessenger.cpp:909

bp-231a2173-8733-4430-9aff-9b5542100129  v3.0.1  Build20100111130305
comment: Saving image attachments
0		@0xffff0084	
1	DesktopServicesPriv	TNode::IsContainer const	
2	DesktopServicesPriv	TNode::SetForceSync	
3	DesktopServicesPriv	TNode::FNNotificationHook	
4	CoreFoundation	__CFXNotificationHandleMessage	
5	CoreFoundation	__CFXNotificationReceiveFromServer	
6	CoreFoundation	__CFMachPortPerform	
7	CoreFoundation	__CFRunLoopRun	
8	CoreFoundation	CFRunLoopRunSpecific	
9	CoreFoundation	CFRunLoopRunInMode	
10	HIToolbox	RunCurrentEventLoopInMode	
11	HIToolbox	ReceiveNextEventCommon	
12	HIToolbox	BlockUntilNextEventMatchingListInMode	
13	AppKit	_DPSNextEvent	
14	AppKit	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]	
15	thunderbird-bin	nsAppShell::ProcessNextNativeEvent	widget/src/cocoa/nsAppShell.mm:665
16	thunderbird-bin	nsBaseAppShell::DoProcessNextNativeEvent	widget/src/xpwidgets/nsBaseAppShell.cpp:151
17	thunderbird-bin	nsBaseAppShell::OnProcessNextEvent	widget/src/xpwidgets/nsBaseAppShell.cpp:278
18	thunderbird-bin	nsAppShell::OnProcessNextEvent	widget/src/cocoa/nsAppShell.mm:844
19	libxpcom_core.dylib	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:508
20	libxpcom_core.dylib	NS_ProcessPendingEvents_P	 nsThreadUtils.cpp:200
Component: General → Widget: Cocoa
Product: Thunderbird → Core
QA Contact: general → cocoa
DesktopServicesPriv has a long history of being the location of problematic crashes (e.g. bug 335061 and all of the 10.6.0/10.6.1 "I used the filepicker and crashed" crashes).

Comment 2

8 years ago
Thanks Smokey.  ref bug 335061 comment 38.
will wait until 3.1 is out a few months and bigger numbers for next evaluation.
(no crashes with email addresses in last 4 weeks)
(Assignee)

Updated

7 years ago
Crash Signature: [@ TNode::IsContainer() const ]

Comment 3

7 years ago
bp-9f8d7fce-bee9-43bf-b5f3-b8a072111125 firefox v9
bp-a3769b04-558d-412a-86b3-2c7202111211 tbird v8
Whiteboard: [rare][tbird crash]

Updated

6 years ago
Duplicate of this bug: 513745

Comment 5

6 years ago
still occurs, but not our code
bp-1bddedd8-24b0-4e21-81bf-a5aeb2121108 TB16

bp-032c1bc9-d11e-4220-b9c4-1c36d2121108 FF16 Mac OS X 10.6.8 10K549
"I was downloading a PDF file from a web site"
	http://www.tamiyausa.com/articles/ln/72/XF-chart-10ml.pdf
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.