Improve nsINode::GetNodeType signature

RESOLVED DUPLICATE of bug 659053

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 659053
8 years ago
6 years ago

People

(Reporter: peterv, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
In bug 540848 I'm adding nsINode::GetNodeType with a signature identical to nsIDOMNode::GetNodeType, because it allows us to share implementations between the two. Ideally nsINode::GetNodeType would just return the nodetype directly instead of through an out param. If we do that we need to add implementations to all dom classes that currently implement nsIDOMNode::GetNodeType, and then add implementations for nsIDOMNode::GetNodeType that just call nsINode::GetNodeType.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 659053
You need to log in before you can comment on or make changes to this bug.