Status

()

Core
Networking
P3
critical
VERIFIED DUPLICATE of bug 52397
18 years ago
18 years ago

People

(Reporter: Alex Trudelle, Assigned: Gagan)

Tracking

({crash})

Trunk
PowerPC
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
using n6 build ID 2000092911 on macOS 8.6
goto url above url
click on bleem radio button
click vote
crash
talk back ID TB18366208Z
can attach macsbug log if needed

Comment 1

18 years ago
Confirming (I had him repeat it 3 times, once after restarting computer).
nominating for nsbeta3 to get on radar until we understand it.
Note: computer was PowerTower Pro 225, not a target machine.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta3
the crash is in networking, in nsOnDataAvailableEvent::HandleEvent(). -->Necko
Assignee: asa → gagan
Component: Browser-General → Networking
Keywords: crash, rtm
QA Contact: doronr → tever
fwiw, this crashes on my target machine as well (G4, 450)

Comment 4

18 years ago
I can't repro. on windows in branch of trunk...could this possibly be mac-only?

(cc'ing myself because I _have_ to watch the trudelle-in-training ;-)

Comment 5

18 years ago
Hmmm.

Followed above instructions, got message from targetsite saying:  "Error
Description: There may have been a error in the html code used to access this
poll or it may have been deleted for one of the following reasons:

Polls that receive no hits and/or votes for a period of 30 days are
automatically deleted.

The Poll may have contained illegal or adult material."

I *did* get a crash when I attempted to vote in the Mozillazine poll on Saturday
morning with Mac OS 9.0.4, build 2000092804.  Attaching my stdlog from MacsBug,
but I think Mike's on the right track. (he's been following it longer than I
have :=}  )
it happens to me on linux.  marking platform as all.

we crash because mChannel is null (line 467, nsHTTPResponseListener.cpp)

#0  0x408ab934 in nsHTTPServerListener::OnDataAvailable (this=0x862f358, 
    channel=0x8be747c, context=0x8a89a90, i_pStream=0x8733650, 
    i_SourceOffset=0, i_Length=1253) at nsHTTPResponseListener.cpp:467
#1  0x4084102f in nsOnDataAvailableEvent::HandleEvent (this=0x42b00c48)
    at nsAsyncStreamListener.cpp:400
#2  0x408402b7 in nsStreamListenerEvent::HandlePLEvent (aEvent=0x42b00c70)
    at nsAsyncStreamListener.cpp:97
#3  0x4012718e in PL_HandleEvent (self=0x42b00c70) at plevent.c:575
#4  0x40126fac in PL_ProcessPendingEvents (self=0x8081b60) at plevent.c:508
#5  0x40128df9 in nsEventQueueImpl::ProcessPendingEvents (this=0x8081b38)
    at nsEventQueue.cpp:356
#6  0x40fa5a44 in event_processor_callback (data=0x8081b38, source=8, 
    condition=GDK_INPUT_READ) at nsAppShell.cpp:158
#7  0x40fa567f in our_gdk_io_invoke (source=0x8292e80, condition=G_IO_IN, 
    data=0x8292e70) at nsAppShell.cpp:58
#8  0x4070852a in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#9  0x40709be6 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#10 0x4070a1a1 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#11 0x4070a341 in g_main_run () from /usr/lib/libglib-1.2.so.0
#12 0x40631209 in ?? () from /usr/lib/libgtk-1.2.so.0
#13 0x40fa613a in nsAppShell::Run (this=0x8215710) at nsAppShell.cpp:335
#14 0x41faa3f4 in nsAppShellService::Run (this=0x81d0860)
    at nsAppShellService.cpp:407
#15 0x80562e5 in main1 (argc=1, argv=0xbffffa14, nativeApp=0x0)
    at nsAppRunner.cpp:1004
#16 0x805698e in main (argc=1, argv=0xbffffa14) at nsAppRunner.cpp:1185
OS: Mac System 8.6 → All

Comment 7

18 years ago
Created attachment 15943 [details]
stdlog from MacsBug on Mozillazine vote crash

Comment 8

18 years ago
dup of 52397 per stack trace...

*** This bug has been marked as a duplicate of 52397 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.