After moving profiles program will not restart with profile on real-time backup drive - "already running" error

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: bgmills, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [invalid?])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.89 Safari/532.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

I tried to move my profile folder using the recommended methods for previous versions, i.e. closed TB, created a new folder location, copied the current profile to the new location, restarted TB, changed the folder locations for local folders and accounts. When I restarted TB I got an error message that said an instance of TB was already running. It did not show up in the Task Manager under apps, processes or services. I looked for profile.ini. It did not exist. I uninstalled TB, restarted and reinstalled it. Same problem. I could not get rid of the invisible running instance even after reinstalling nor could I restore the previous profile. I had to uninstall, run system restore to 24 hrs. previous. Then reinstall again. Then it restarted but with no profile. I then reset the profile path to my original profile and restarted TB. Then it worked as before. Now I am afraid to try to move it. The help files are sadly out of date. Please fix this problem or update the documentation so that it works and let me know when it is fixed. I have many clients to whom I have recommended TB but now I am afraid that they have upgraded to 3.0x and will be calling with angry complaints.

Reproducible: Always
Hi Bruce. It's fairly unclear what's happening because, honestly, your report could be better. right now it is difficult to give useful advice. 
* you mention "methods" but don't cite the source, nor what you did.  
* you mention an error message, but don't cite the exact text. 
* you looked for profile.ini where?
* and, why did you need to move your profile in the first place?

This sounds like a support issue, but let's see what we can accomplish with a first pass of Q&A to get this sorted. In addition to the above, before copying the profile from the original source (which I assume is what you did), did you cleanly shut down thunderbird?
(Reporter)

Comment 2

9 years ago
All of the information is in my original description. I keep my mail folders in directory outside of User/AppData which is on a real-time backup system and also for portability for travel purposes. I have copied or moved the profile folder many many times in the past without a hitch. After installing version 3.x I had to relocate the mail folder to another drive. I stopped TB, copied the profile folder, restarted TB and reset the account directory paths. The next time I started TB, I kept getting a message that there was already an instance running yet it was not detectable on the desktop or in the Task Manager apps or processes. Even restarting did not clear it. This led to a lengthly re-installation and reconstruction of the mail client. 

I have since had similar problems with the most recent upgrade of FireFox (on more than one workstation - vista and XP). After closing and reopening it later, I get the same message that says it cannot start because an instance is already running. At least in this case, there is a FireFox process visible in the Task Manager that can be killed.

I have been using FF and TB since v 1.0 and have never had these problems until the most recent upgrades.
Real time backup systems/things which touch thunderbird profile files cause such problems. You'd no doubt be more stable using portable thunderbird and a USB.

Part of the message is probably "already running". Again, the actual text would be helpful
Summary: After moving profiles program will not restart → After moving profiles program will not restart with profile on real-time backup drive - "already running" error
Whiteboard: [invalid?]
Version: unspecified → 3.0
The most common case of getting spurious "<process> is already running" errors is when the .parentlock or parent.lock file was left in the directory. Deleting that file usually fixes the problem. I don't see any evidence of more reproducible data in here, so I will close this as INCOMPLETE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.