Closed Bug 548692 Opened 12 years ago Closed 10 years ago

Running xpcshell tests adds "iniparser01.ini.new" and other files to source directory

Categories

(Testing :: XPCShell Harness, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 671570

People

(Reporter: mossop, Unassigned)

References

Details

Building Firefox is creating these files in my source dir rather than the obj dir:

xpcom/tests/unit/data/iniparser01.ini.new
xpcom/tests/unit/data/iniparser02.ini.new
xpcom/tests/unit/data/iniparser03.ini.new
xpcom/tests/unit/data/iniparser04.ini.new
xpcom/tests/unit/data/iniparser05.ini.new
xpcom/tests/unit/data/iniparser06.ini.new
xpcom/tests/unit/data/iniparser07.ini.new
xpcom/tests/unit/data/iniparser08.ini.new
xpcom/tests/unit/data/iniparser09.ini.new
xpcom/tests/unit/data/iniparser10.ini.new
xpcom/tests/unit/data/iniparser11.ini.new
xpcom/tests/unit/data/iniparser12.ini.new
xpcom/tests/unit/data/iniparser13.ini.new
xpcom/tests/unit/data/iniparser14.ini.new
xpcom/tests/unit/data/iniparser15.ini.new
xpcom/tests/unit/data/non-existant-file.ini

pls fix kthxbye
Looks like we need to nsinstall the data files, so that do_get_file() returns references to $objdir.
We currently do this:
http://mxr.mozilla.org/mozilla-central/source/config/rules.mk#150

which should basically be doing something like:
nsinstall unit/whatever unit/data ../../_tests/xpcshell/xpcom/unit

I guess that will symlink the 'data' dir.
Any chance of fixing the spelling of "existant" while we're there? ;-)
Can someone please own this?
Assignee: dolske → nobody
Component: XPCOM → XPCShell Harness
Product: Core → Testing
QA Contact: xpcom → xpcshellharness
Summary: Build is adding new files to my source directory → Running xpcshell tests adds "iniparser01.ini.new" and other files to source directory
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671570
You need to log in before you can comment on or make changes to this bug.