Closed Bug 548704 Opened 10 years ago Closed 10 years ago

Plugin-problem UI should use browser locale direction, not the page's.

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 555289

People

(Reporter: Dolske, Unassigned)

References

Details

Attachments

(1 file)

Attached patch Patch v.1Splinter Review
The plugin-problem UI is localized by the browser, and should thus use the correct directionality. Eg, a LTR page in a Persian-locale Firefox should display the UI in RTL mode, while a RTL page in a English-locale Firefox should display the UI in LTR mode.
Attachment #429033 - Flags: review?(ehsan.akhgari)
(I have reftests for a separate bug to check this, though I'm not sure how to force browser RTL-mode to check that the UI is RTL in a LTR page. But LTR in a RTL page works with this page.)
err, works with this *patch*. not page.
You need to have tests for this.  You just have to set the intl.uidirection.en-US pref to "rtl" to turn the browser into RTL mode, do the test, and reset it to restore the status of the browser.
Comment on attachment 429033 [details] [diff] [review]
Patch v.1

r=me pending the tests.
Attachment #429033 - Flags: review?(ehsan.akhgari) → review+
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555289
You need to log in before you can comment on or make changes to this bug.