Closed Bug 548799 Opened 12 years ago Closed 12 years ago

Failed to compile Firefox trunk code on OpenSolaris

Categories

(Firefox Build System :: General, defect)

x86
Solaris
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 548218

People

(Reporter: eagle.lu, Assigned: eagle.lu)

Details

Attachments

(1 obsolete file)

When building Firefox trunk code on OpenSolaris x86 platform, I got following errors:
/export/home/SS12/bin/CC -o mozStorageConnection.o -c -xldscope=hidden -DSQLITE_MAX_LIKE_PATTERN_LENGTH=50000 -DMOZILLA_INTERNAL_API -DMOZ_THUNDERBIRD=1 -DOSTYPE=\"SunOS5\" -DOSARCH=SunOS  -I/export/home/brian/moz-ws/community3/0226/comm-central/mozilla/storage/src -I. -I../../dist/include -I../../dist/include/nsprpub  -I/export/home/brian/moz-ws/community3/0226/thunderbird/mozilla/dist/include/nspr -I/export/home/brian/moz-ws/community3/0226/thunderbird/mozilla/dist/include/nss       -KPIC  -xlibmieee -xbuiltin=%all -features=tmplife -norunpath -mt  -DDEBUG -D_DEBUG -DDEBUG_brian -DTRACING -g -features=extensions -D__FUNCTION__=__func__   -DMOZILLA_CLIENT -D_MOZILLA_CONFIG_H_ -DMOZILLA_VERSION=\"1.9.3a2pre\" -DMOZILLA_VERSION_U=1.9.3a2pre -DSOLARIS=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_MMINTRIN_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1 -DHAVE_DLADDR=1 -DHAVE_LIBSOCKET=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -DHAVE_FT_BITMAP_SIZE_Y_PPEM=1 -DHAVE_FT_GLYPHSLOT_EMBOLDEN=1 -DHAVE_FT_LOAD_SFNT_TABLE=1 -DHAVE_FT_SELECT_SIZE=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_STAT64=1 -DHAVE_LSTAT64=1 -DHAVE_TRUNCATE64=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1 -DHAVE_CLOCK_MONOTONIC=1 -DHAVE_LANGINFO_CODESET=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DHAVE_THREAD_TLS_KEYWORD=1 -DHAVE_I18N_LC_MESSAGES=1 -DMOZ_BUILD_APP=../mail -DMOZ_DEFAULT_TOOLKIT=\"cairo-gtk2\" -DMOZ_X11=1 -DMOZ_WIDGET_GTK2=1 -DMOZ_ENABLE_XREMOTE=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DMOZ_PANGO=1 -DMOZ_ENABLE_GNOMEVFS=1 -DMOZ_ENABLE_GCONF=1 -DMOZ_ENABLE_LIBNOTIFY=1 -DMOZ_ENABLE_GNOMEUI=1 -DMOZ_ENABLE_DBUS=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILITY=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_WAVE=1 -DMOZ_SYDNEYAUDIO=1 -DMOZ_MEDIA=1 -DMOZ_XTF=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DMOZ_MATHML=1 -DMOZ_SVG=1 -DMOZ_SMIL=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_FEEDS=1 -DMOZ_STORAGE=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMOZ_LOGGING=1 -DMOZ_CHROME_FILE_FORMAT_JAR=1 -DMOZ_USER_DIR=\".mozilla\" -DHAVE_STDINT_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_SYS_INT_TYPES_H=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF=1 -DBUILD_CTYPES=1 -DMOZ_MORK=1 -DMOZ_DLL_SUFFIX=\".so\" -DHAVE_FONTCONFIG_FCFREETYPE_H=1 -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DMOZ_REFLOW_PERF=1 -DMOZ_REFLOW_PERF_DSP=1 -DMOZ_ACCESSIBILITY_ATK=1 -DATK_MAJOR_VERSION=1 -DATK_MINOR_VERSION=28 -DATK_REV_VERSION=0  /export/home/brian/moz-ws/community3/0226/comm-central/mozilla/storage/src/mozStorageConnection.cpp 

      "/export/home/brian/moz-ws/community3/0226/comm-central/mozilla/storage/src/variantToSQLiteT_impl.h", line 56: Error: Reference to static mozilla::storage::sqlite3_T_null(sqlite3_context*) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.                                                                                                                                        
"/export/home/brian/moz-ws/community3/0226/comm-central/mozilla/storage/src/mozStorageConnection.cpp", line 199:     Where: While instantiating "mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*)".
"/export/home/brian/moz-ws/community3/0226/comm-central/mozilla/storage/src/mozStorageConnection.cpp", line 199:     Where: Instantiated from non-template code.
"/export/home/brian/moz-ws/community3/0226/comm-central/mozilla/storage/src/variantToSQLiteT_impl.h", line 70: Error: Reference to static mozilla::storage::sqlite3_T_int(sqlite3_context*, int) not allowed in template mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*), try using -features=tmplrefstatic.
"/export/home/brian/moz-ws/community3/0226/comm-central/mozilla/storage/src/mozStorageConnection.cpp", line 199:     Where: While instantiating "mozilla::storage::variantToSQLiteT<sqlite3_context*>(sqlite3_context*, nsIVariant*)".
"/export/home/brian/moz-ws/community3/0226/comm-central/mozilla/storage/src/mozStorageConnection.cpp", line 199:     Where: Instantiated from non-template code.

We should add -feature=tmplrefstatic  to CXXFLAGS
Assignee: nobody → brian.lu
Attachment #429105 - Flags: review?(wtc)
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548218
Comment on attachment 429105 [details] [diff] [review]
Add -features=tmplrefstatic to CXXFLAGS

The patch is on wrong direction.
Attachment #429105 - Attachment is obsolete: true
Attachment #429105 - Flags: review?(wtc)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.