winmo debug build warns "oops, somebody didn't override CreateFontInstance"

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

Trunk
x86
Windows Mobile 6 Standard
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
This happens because gfxFontGroup::BuildFontList tries to work via the platformFontList structure, which calls gfxFontEntry::CreateFontInstance, but the FT2 font system has not yet been updated to support this. Fonts still work because the gfxFT2FontGroup then implements its own font-list construction, so the failure of BuildFontList is not fatal, merely wasteful.

As an interim measure, until FT2Fonts are fully migrated to the newer font-list interfaces, we should simply #ifdef out the body of BuildFontList for mobile builds.
(Assignee)

Comment 1

8 years ago
Created attachment 429167 [details] [diff] [review]
patch, v1: stub out gfxFontGroup::BuildFontList on mobile

Patch to eliminate the body of BuildFontList on mobile builds for now. Not yet tested....
this eliminates the warning and doesn't seem to break anything
Attachment #429167 - Flags: review?(jdaggett)

Updated

8 years ago
Attachment #429167 - Flags: review?(jdaggett) → review+
(Assignee)

Comment 3

8 years ago
pushed http://hg.mozilla.org/mozilla-central/rev/1be367fbed9c
Assignee: nobody → jfkthame
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 548184
You need to log in before you can comment on or make changes to this bug.