Javascript apparently not picked up on this URL

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: thaynes, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20000925
BuildID:    2000092505

Loading up this page displays							
Your browser does not support JavaScript
The Firewall Design Tool requires JavaScript capability.

Javascript is enabled on this browser for the browser only (i.e. not News or
Mail). Looking at the page source, it looks like we are getting the <NOSCRIPT>
</NOSCRIPT> part of the page rather than running the Javascript immediately
after the above section.

Reproducible: Always
Steps to Reproduce:
Load the above page			

Actual Results:  Your browser does not support JavaScript
The Firewall Design Tool requires JavaScript capability.				

Expected Results:  Frames containing Javascipt tool to build firewall settings.

Comment 1

18 years ago
*** Bug 54891 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Browser, not engine. --> DOM 0
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 3

18 years ago
Seeing this on Mac OS 9.0.4 as well.  Mozilla build 2000100208-M18.

Comment 4

18 years ago
Created attachment 17035 [details]
Evil NOSCRIPT tag outside of BODY.

Comment 5

18 years ago
Fails for me too, Win32/2000101108. The document looks malformed to me, in that 
there shouldn't be tags between the end of the HEAD and start of the BODY. 
However, the behaviour is different from both NN classic and IE.

Comment 6

18 years ago
*** Bug 56434 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Depends on: 56501

Comment 7

18 years ago
Notice , too, that the HTML at the given URL contains both <BODY> and 
<FRAMESET> tags. Doesn't that in itself make the HTML invalid? 


This is also the case at the duplicate bug 56434. The only difference is 
that in bug 56434, the <FRAMESET> tags are static, whereas here they are
written dynamically.
No longer depends on: 56501

Comment 8

18 years ago
Looks like the parser workaround for <NOSCRIPT> under bug #56501 has nailed this
one too. Works for me now (both the original pages and the test case) on
Win98/Gecko 2000101808.
(Assignee)

Comment 9

18 years ago
--> WORKSFORME now too
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.