Closed Bug 549058 Opened 10 years ago Closed 7 years ago

-compose syntax regression affecting attachments

Categories

(Thunderbird :: OS Integration, defect, major)

All
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 627999

People

(Reporter: oxmosys, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/532.9 (KHTML, like Gecko) Chrome/5.0.307.9 Safari/532.9
Build Identifier: 3.0.2

Thunderbird 3.0.2 has two important regressions in the way it handle arguments of -compose command line option compared to Thunderbird 2.0 :

This used to work perfectly with thunderbird 2.0 :
thunderbird -compose "attachment='file:///scan%2D0.pdf,'"

With Thunderbird 3.0.1, It shows a error message that say : "An error occurred while creating a message compose window. Please try again." This is caused by the virgule at the end of the attachment. 

If we remove this virgule, thunderbird hit another regression, the attachment filename is not renamed to scan-0.pdf, therefore thunderbird is not able to find scan%2D0.pdf .

That does not make sense, because URLencoded filenames is necessary here to seperate each file correctly.

xdg-email recently included a fix to add Thunderbird compatibility for Linux operating systems, because Thunderbird does not support attachments with mailto. These two regressions unfortunately break this recent fix, and prevent all applications to send email attachments when Thunderbird 3 is set as the default email client on Linux.

Summary :
1. Thunderbird show a error msg when there is a virgule at the end of last attachment filename.
2. Thunderbird does not convert URLEncoded filenames to normal strings, leading it to think that the file does not exist anymore.

This has been tested under Windows XP as well.

Reproducible: Always

Steps to Reproduce:
1. Create a file named scan-0.pdf at the root of your filesystem (/)
2. Attach the file in thunderbird via command line : thunderbird -compose "attachment='file:///scan%2D0.pdf,'" (Linux) or thunderbird.exe -compose "attachment='file://C:/scan%2D0.pdf,'" (Windows).
Actual Results:  
Thunderbird ends on a error message saying "An error occurred while creating a message compose window. Please try again." because of the virgule. And without the virgule, it attach scan%2D0.pdf to the message.

Expected Results:  
Thunderbird should not report any error and simply ignore the virgule, as it did in the past, and it should convert the filename to scan-0.pdf.

This issue is also tracked in launchpad bug :
https://bugs.launchpad.net/simple-scan/+bug/515386
Moving to OS Integration component, seems there is no way to pass special characters in attachments from the CLI to have the proper files be attached.  I can confirm this on:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9pre) Gecko/20100309 Lightning/1.0b1 Shredder/3.0.4pre on Ubuntu Karmic
Status: UNCONFIRMED → NEW
Component: General → OS Integration
Ever confirmed: true
QA Contact: general → os-integration
Micah Gersten : As a reminder, this bug also affect Windows. -compose syntax is broken here as well. However sending attachments from Windows explorer, or Picasa works, which means that Windows probably use some different way to attach files in thunderbird than the -compose CLI syntax. 

But if someone was to manually use -compose under Windows, he would be in the exact same situation.
> Windows probably use some different way to attach files in thunderbird

Yes, MAPI. We support that.
I appear to be affected by this bug on two Ubuntu systems (one Maverick, one Jaunty).  Picasa can no longer e-mail photos since I upgraded to Thunderbird 3 on both systems.
This bug prevents me to send my files scanned with simple-scan by email when using the "File", "Mail" menu of simple-scan.

I am using Ubuntu 12.04 and Thunderbird 15.

Very poor experience for Ubuntu users :-(
Version: unspecified → Trunk
Vincent, your issue is likely not this one. I think this was bug 627999. 

See http://kb.mozillazine.org/Command_line_arguments_(Thunderbird) for syntax.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 627999
You need to log in before you can comment on or make changes to this bug.