Delete (not empty) from trash -> Undo option available -> causing restoration of a 'null' mail

RESOLVED DUPLICATE of bug 209189

Status

RESOLVED DUPLICATE of bug 209189
9 years ago
9 years ago

People

(Reporter: desaparecido, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.8) Gecko/20100216 Thunderbird/3.0.2

Hi,
if you delete a mail it will appear in the trash folder. If you press delete in there, the undo function is not disabled.

Pressing undo will not restore the mail (what is in my opinion correct bahaviour) but it tries to. So a 'null' mail (emty header & body, date 01.01.1970 you surely know) appears in the location the mail was deleted at first time.

Possible solution: disable undo option or replace it to a 'Undo not possible' dummy action if you want to keep the undo/redo history

Reproducible: Always

Steps to Reproduce:
please refer to details.
Actual Results:  
please refer to details.

Expected Results:  
please refer to details.
(Reporter)

Comment 1

9 years ago
I also tested the behaviour, when emptying the trash bin. The undo option after that is also available, but no email will be restored.

So another possibility would be to implement this strategy, so it would be a bit more consistent. (I would try this on my own, but by now I didn't find the proper page to join as a programmer for the Mozilla project.)
(Reporter)

Comment 2

9 years ago
as far as i can see there won't be an easy solution for this, because deleting has an canUndo property in general.

if (canUndoOrRedo)
  {
    var commands =
      ['valueDefault', 'valueDeleteMsg', 'valueMoveMsg', 'valueCopyMsg', 'valueUnmarkAllMsgs'];
    goSetMenuValue(command, commands[txnType]);
  }

But i'm still looking
(Reporter)

Comment 3

9 years ago
I was trying to debug this with venkman, but I didn't get so far. By now I just found the corresponding moveCopyCompleted-event. But I can't figure out where it's dispatched. If someone likes to help would really appreciate it
(Sorry for my probably bad English, I'm from Germany...)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 209189
You need to log in before you can comment on or make changes to this bug.