Closed Bug 549095 Opened 10 years ago Closed 10 years ago

No WYSIWYG editor in Open CMS

Categories

(Core :: General, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED INVALID

People

(Reporter: meremitch, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.18) Gecko/2010021619 Camino/2.0.2 (like Firefox/3.0.18)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.18) Gecko/2010021619 Camino/2.0.2 (like Firefox/3.0.18)

I am a webmaster, and edit in Open CMS every day.  With the latest FireFox and Camino BOTH, the WYSIWYG editor in Open CMS system is not functional.  This problem has been stated by others, but I want to emphasize that this is a serious problem.  I hope it can be repaired quickly!!!!!!!!!!
All the many editors I know are frustrated with this problem.

Reproducible: Always

Steps to Reproduce:
1. In Open CMS, try to go to WYSIWYG editor
2.
3.
Actual Results:  
Only the source HTML file is available for editing.

Expected Results:  
Appearance of the WYSIWYG editor.
--> Core for triage, since it happens in Camino and Firefox. Please let us know what Firefox version you're testing against, and provide a sample URL where it can be tested.
Product: Camino → Core
QA Contact: general → general
This bug's steps to reproduce seem to be missing some URLs to pages that actually show the problem...

And yes, which Firefox version are you using?  And is the "User-Agent" string in comment 0 correct for the Camino that's showing the bug?
I had installed the very latest version of each.  Earlier versions allowed for WYSIWYG
(In reply to comment #3)
> I had installed the very latest version of each.  Earlier versions allowed for
> WYSIWYG editing.  I have reverted to an earlier version of both browsers, and can now use the WYSIWYG editor.  It's unfortunate that later versions have done something to remove that capability.
Which latest versions?  For Firefox, did you install 3.6, or 3.7a1, or a nightly?  Which exact Camino were you using?

And this bug _still_ needs a way to reproduce the problem.

Honestly, I'd love to help you figure out what's going on here, but I need more information from you than just "it doesn't work" without even telling me what "it" is...
I'll try to make myself clearer.  Open CMS provides a WYSIWYG editor to edit web pages. When I downloaded the lates versions of Firefox and then of Camino, when I tried to edit a page, I was shown only the source code of the page.  The WYSIWYG editor could not be accessed.  In fact, it didn't even appear, as it has in the past,"it" being the WYSIWYG editor.
Under normal, desireable conditions, I log on and am shown all the pages in the website for which I am responsible. I click on "edit" to edit a page, and a new page opens with the page appearing as it would on the site, and above it lies all the tools available for editing the page.  I can and or delete words, change the font size or type, center, and click on an icon to add a picture or another to add a link. Another button enables me to go the source and edit the source code if I desire. However, in the new versions, when I click on "edit," a new page opens with the source code -- period. I can certainly edit that way, but it's much easier and faster to edit with the WYSIWYG editor, which is not accessible in the latest versions of Firefox and Camino.
I hope that's clear.
Meredith, can you please supply some specifics about both the browsers you are using this Open CMS?  

That is, from Camino menu (and the Firefox menu in Firefox), select "About Camino" (and "About Firefox") and copy the version information and paste it in this bug?

Also, when you try to access this Open CMS, what is the URL that is in your location bar?  Does this Open CMS display a version number anywhere?

--

That said, if the "Open CMS" CMS in question is this Open CMS (http://cvs.opencms.org/viewvc.cgi/opencms/modules/org.opencms.editors.fckeditor/resources/system/workplace/editors/fckeditor/editor_configuration.xml?r1=1.5&r2=1.6) and the particular Open CMS installation in use hasn't been updated to the latest code, then there's a good chance that this is all the Year 2010 bug in FCKEditor: http://www.petefreitag.com/item/737.cfm
Meredith, comment 6 just happens to not supply the information I asked for which is:

1)  Exact Camino and Firefox version numbers (or at least exact urls downloaded
    from).
2)  The url where you see the problem.

Comment 7 gives some steps for providing the necessary information, though; so it would be great if you could do that.
Smokey, when I try edit an Open CMS file in Firefox (version 3.6) the URL is the site that I am webmaster for. The version of Open CMS is not relevant.  I reverted back to Camino 1.6.8 because the latest version does the same thing as the latest version of Firefox.

Boris, I've specified the versions of Firefox and Camino in the above paragraph.  I am webmaster for 2 microsites in the portal built under Open CMS. The effect is the same when I edit either microsite.

The URL is unimportant, but if you are seriously interested, it's sctxcompclub.org, and I'm webmaster for the computer and china clubs.  The important fact is that the editor worked fine in earlier versions of Firefox and Camino, but it (the WYSIWYG editor) does not appear in the later versions. 

I don't know how I can make this clearer.  I thought I spelled out precisely what was happening in my previous comment.  How can I make myself clearer. 
Is either of you familiar with content management systems, of which Open CMS is one?  You don't seem to understand my issue.
> Is either of you familiar with content management systems

No, we're familiar with web browsers!  That's the whole point.

I understand the issue fine ("editing doesn't work on this web site"); I'm just trying to figure out which exact software called "Open CMS" you're using so that I can try to figure out how to reproduce the issue and then try to figure out how to fix it.  It sounds like there's no way I can load the pages in question myself to reproduce the bug, right?  (In the sense that this would involve you giving me your password or something to make it happen; not something either one of us wants at this point, I bet.)

Thank you for clarifying that the issue is happening in Firefox 3.6.

If the "Open CMS" you're using is this one: http://www.opencms.org/en/ then the end of comment 7 is indeed likely to be the problem.  The link there is to a recent change in the code for that "Open CMS" which fixes a longstanding bug in the program.  The old code fails to work in any Gecko-based browser compiled in 2010 (as Firefox 3.6 is).

Could you maybe test that hypothesis?  For example, can you try Firefox 3.5.7 (which should work fine if the hypothesis is correct) and then try Firefox 3.5.8 (which should fail to work if the hypothesis is correct)?
We are using Open CMS version 6.2.1.  The WYSIWYG editor does appear in Firefox version 3.5.7 but not in 3.5.7.  It does not appear also in any Camino version later than 1.6.8. It appears that your hypothesis is correct if your premises are correct, and I'm not familiar with what led to them.  

I visited the link you provide to Open CMS, but I couldn't find any comments on the home page. Is there a link to the comment area?

I have no authority to change the version of Open CMS that is being used here, and if ugrading to a later version is required, I don't know how much work that would entail. Does the fix have to come from Open CMS or can Mozilla make a fix? Or do I simply accept my fate and stay with old versions of Firefox and Camino?
Meredith, the problem is that there is code in the OpenCMS in question that interrogates Firefox as to when it was released and fails if it was released in a year that does not start with the string "200".  There's nothing we can do on our side to fix that short of lying about the release year, which would almost certainly break other websites.

The first link at the end of comment 7 shows the change the OpenCMS developers made on their end to fix the problem: they changed the regular expression "^Mozilla/5\.0 \(.* rv:1\..*\) Gecko/200\d* .*$" to the regular expression "^Mozilla/5\.0 \(.*\) Gecko/20\d* .*$".

It looks like this fix was released in OpenCMS 7.5.2.  As far as I can tell from their site the 6.2.x versions are no longer being maintained (with the last update in July 2006)...

I don't see any obvious user forums on their site, but I'm not exactly familiar with OpenCMS, as I said.

If you don't have the option of upgrading to an OpenCMS release that fixes the problem, you may be able to work around it by spoofing your user-agent string so that OpenCMS thinks you're using a browser from 2009 or earlier.  As I said, this might break other sites, but that may be a reasonable risk for you depending on what other sites you use.  Chances are it won't be a problem.  Let me know if you want to try doing this and I'll hunt up the directions for you.

Thank you very much for following up on this and for your help figuring out what's going on here.  I'm sorry there isn't anything we can do on our end to work around this OpenCMS problem.

Resolving as invalid (which basically means "not a bug in our code"; not a reflection on you in any way!).
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Oh, one other thing.  You can't really "stay with old versions of Firefox" to avoid the problem, unless you stop installing security updates.  Any security update released at this point will trigger the issue.

So I suspect you really do want to spoof the user-agent, at least in the short term.
In addition to what Boris has already said,

(In reply to comment #11)
 > I have no authority to change the version of Open CMS that is being used here,
> and if ugrading to a later version is required, I don't know how much work that
> would entail.

You should be sure to report this problem to whomever is responsible for maintaining/upgrading the OpenCMS installation for your website.

It's *possible* that the problem can be fixed just by fixing the regular expression, without needing to perform a complete upgrade, but whoever is responsible for maintaining/upgrading the OpenCMS at your site should check with the OpenCMS developers.  However, just like with web browsers, web software packages like CMSes really should be upgraded regularly to keep up with security fixes in the software.
Thank you Boris and Smokey.  I have forwarded your comments to the Portal Webmaster who is the only person that might be able to take an appropriate action, whatever he deems that to be.  I deeply appreciate your continued dedication to responding to my issue.  If there is any reason to continue this dialog, I'll report in an additional comment when I hear back from the big chief.
You need to log in before you can comment on or make changes to this bug.