Multiple location bar results appear selected when scrolling down

VERIFIED FIXED

Status

()

Core
Graphics
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: u88484, Assigned: bas)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

8 years ago
Multiple location bar results appear selected when scrolling down

STR:
1) Type g in location bar (or some other letter that you know will show a lot of results)
2) Press the down arrow key until the results begin to scroll
3) Note multiple results showing as being selected

This does not happen in the downloads manager.

Windows 7 64-bit
NVIDIA GeForce 7150M / nForce 630M
Drivers: 7.15.11.7967

Comment 1

8 years ago
Are they actually selected, or do they just appear as though they are?
(Reporter)

Comment 2

8 years ago
Just appear.  The last selection is what opens up when the enter key is pressed.
I can confirm this. Only seeing this after enabling Direct2D rendering.

Windows 7 x64
ATI Radeon HD5770
Driver 8.690.0.0
(Reporter)

Comment 4

8 years ago
Could this bug be related to multiple ctrl+tab multiple selections?

http://img30.imageshack.us/img30/3489/ctrltab.jpg
(Assignee)

Comment 5

8 years ago
So, this is interesting, the window is scrolled up correctly, but it seems the part of the window containing the URL that used to be selected is not invalidated, so the unselected URL is never drawn there. I don't have a good idea yet what causes this.
(Assignee)

Comment 6

8 years ago
Created attachment 430132 [details]
AwesomebarScrollArtifact

Add a screenshot of the effect.
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
Status: ASSIGNED → NEW
(Assignee)

Comment 7

8 years ago
Created attachment 430168 [details] [diff] [review]
Fix scrolling invalidation for D2D

This patch fixes the invalidation when scrolling, by doing what ScrollWindowEx seems to do for the updateRgn. That is, it 'smears' the invalidation area with the scroll. I essentially takes the union of the current update region and the update region moves by the scroll.
Attachment #430168 - Flags: review?(jmuizelaar)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 549953
Can't you just move the region?
(Assignee)

Comment 10

8 years ago
Created attachment 430186 [details] [diff] [review]
Fix scrolling invalidation for D2D v2

I believe that roc's right looking at our code. It doesn't seem to be what ScrollWindowEx does. But it seems to work just fine in all situations I tested, so I suggest we do this.
Attachment #430168 - Attachment is obsolete: true
Attachment #430168 - Flags: review?(jmuizelaar)
(Assignee)

Updated

8 years ago
Attachment #430186 - Flags: review?(jmuizelaar)
(In reply to comment #10)
> Created an attachment (id=430186) [details]
> Fix scrolling invalidation for D2D v2
> 
> I believe that roc's right looking at our code. It doesn't seem to be what
> ScrollWindowEx does. But it seems to work just fine in all situations I tested,
> so I suggest we do this.

Can't we just use OffsetRgn instead of doing this by hand?
Attachment #430186 - Flags: review?(jmuizelaar) → review-
(Assignee)

Comment 12

8 years ago
Created attachment 430343 [details] [diff] [review]
Fix scrolling invalidation for D2D v3

Thanks for pointing me at the GDI function I couldn't find!!
Attachment #430186 - Attachment is obsolete: true
Attachment #430343 - Flags: review?(jmuizelaar)
Attachment #430343 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 13

8 years ago
Pushed, changeset 103b23e9a222.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified fixed using:

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100304 Minefield/3.7a3pre Firefox/3.6 ID:20100304141831 <latest hourly

cset: 20100304141831 5125fc26166b
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.