Crash when reading news postings after 1st reading/writing e-mail [@ arena_malloc_small] - [@ orkinHeap::Alloc - morkNext::MakeNewNext]

RESOLVED DUPLICATE of bug 530044

Status

MailNews Core
Database
--
critical
RESOLVED DUPLICATE of bug 530044
8 years ago
7 years ago

People

(Reporter: Peter, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 3.0.2

If I start reading usenet news as soon as I open TB, it seems stable.  However, if I open TB, read, write e-mail 1st, then select one of subscribed usenet newsgroups with new mail in left-sided pane, TB crashes either at that time, or when I select the 1st unread msg in right-sided pane.  Problem is intermittent.  Reopening TB and repeating the same behavior ALWAYS reproduces the crash.  Solution: Rebuild the index of that specific newsgroup that is causing the crash.

Reproducible: Sometimes

Steps to Reproduce:
1.  Reopen TB and select the same usenet newsgroup or msg that previously caused crash.
2.
3.
Actual Results:  
Reliably recrashes unless I rebuild the index for that specific newsgroup.

Expected Results:  
Not crash!

See crash report ID: bp-d38d7c4d-353f-425a-b8a9-c5fb22100226

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 530044

Comment 2

8 years ago
I expect Peter will be updating the bug shortly

bp-d38d7c4d-353f-425a-b8a9-c5fb22100226 v3.0.2 crash
0	mozcrt19.dll	arena_malloc_small	 objdir-tb/mozilla/memory/jemalloc/src/jemalloc.c:3715
1	mozcrt19.dll	malloc	objdir-tb/mozilla/memory/jemalloc/src/jemalloc.c:5785
2	mozcrt19.dll	operator new	objdir-tb/mozilla/memory/jemalloc/src/new.cpp:54
3	thunderbird.exe	orkinHeap::Alloc	db/mork/src/orkinHeap.cpp:90
4	thunderbird.exe	morkNext::MakeNewNext	db/mork/src/morkNode.cpp:182
5	thunderbird.exe	morkTable::NewTableRowCursor	db/mork/src/morkTable.cpp:1540
6	thunderbird.exe	morkTable::GetTableRowCursor	db/mork/src/morkTable.cpp:458
7	thunderbird.exe	nsMsgThread::GetChildHdrAt	mailnews/db/msgdb/src/nsMsgThread.cpp:533
8	thunderbird.exe	nsMsgThread::GetChildHdrForKey	mailnews/db/msgdb/src/nsMsgThread.cpp:1069
9	thunderbird.exe	nsMsgThread::GetRootHdr	mailnews/db/msgdb/src/nsMsgThread.cpp:956
10	thunderbird.exe	nsMsgThreadEnumerator::nsMsgThreadEnumerator	mailnews/db/msgdb/src/nsMsgThread.cpp:699
11	thunderbird.exe	nsMsgThread::EnumerateMessages	mailnews/db/msgdb/src/nsMsgThread.cpp:905
12	thunderbird.exe	nsMsgQuickSearchDBView::ListIdsInThreadOrder	mailnews/base/src/nsMsgQuickSearchDBView.cpp:662
13	thunderbird.exe	nsMsgQuickSearchDBView::ListIdsInThreadOrder	mailnews/base/src/nsMsgQuickSearchDBView.cpp:704 
...
16176	thunderbird.exe	nsMsgQuickSearchDBView::ListIdsInThreadOrder	 mailnews/base/src/nsMsgQuickSearchDBView.cpp:704
16177	thunderbird.exe	nsMsgQuickSearchDBView::ListIdsInThreadOrder	mailnews/base/src/nsMsgQuickSearchDBView.cpp:704
16178	thunderbird.exe	nsMsgQuickSearchDBView::ListIdsInThreadOrder	mailnews/base/src/nsMsgQuickSearchDBView.cpp:736
16179	thunderbird.exe	nsMsgQuickSearchDBView::SortThreads	mailnews/base/src/nsMsgQuickSearchDBView.cpp:552
16180	thunderbird.exe	nsMsgThreadedDBView::Sort	mailnews/base/src/nsMsgThreadedDBView.cpp:361
16181	thunderbird.exe	nsMsgQuickSearchDBView::OnSearchDone	mailnews/base/src/nsMsgQuickSearchDBView.cpp:356
16182	thunderbird.exe	nsMsgSearchSession::NotifyListenersDone	mailnews/base/search/src/nsMsgSearchSession.cpp:598
16183	thunderbird.exe	nsMsgSearchSession::TimerCallback	mailnews/base/search/src/nsMsgSearchSession.cpp:538
16184	xpcom_core.dll	nsTimerImpl::Fire	xpcom/threads/nsTimerImpl.cpp:420
Severity: major → critical
Component: Message Reader UI → Database
Keywords: crash
Product: Thunderbird → MailNews Core
QA Contact: message-reader → database
Summary: Crash when reading news postings after 1st reading/writing e-mail → Crash when reading news postings after 1st reading/writing e-mail [@ arena_malloc_small] - [@ orkinHeap::Alloc - morkNext::MakeNewNext]
Version: unspecified → 1.9.1 Branch

Comment 3

8 years ago
ok, i don't get it, this isn't fixed...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

8 years ago
Don't know what I can or should add to my original bug report except that this issue occurs almost exclusively when trying to read mozilla.support.thunderbird hosted on news.mozilla.support   I also subscribe to several newgroups on news.albasani.net, news. eternal-september.org, and on textnews.news.cambrium.nl and in fact I can't recall if I ever experienced the problem when clicking on any of the subscribed newsgroups from those other news servers.   (I've previously tried entirely deleting and re-establishing my subscription to news.mozilla.support and since that of course requires rebuilding the index for mozilla.support.thunderbird, things work well the initial time, but then the problem recurs unpredictably.  Several weeks or months ago I previously posted a msg in mozilla.support.thunderbird asking if there was something unique in the way this group is configured or indexed compared with other groups on other servers and at least 1 reply indicated that the answer to that question was "no."
(Reporter)

Comment 5

8 years ago
Since the TB 3.0.3 upgrade, I've been unable to provoke the crashes I described in this bug report.  For me, 3.0.3 fixed whatever was causing this behavior and I regard this bug as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Comment 6

8 years ago
I think this really was a dup after all. I'm not sure why timeless said it wasn't fixed...
Resolution: FIXED → DUPLICATE
Duplicate of bug: 530044
(Reporter)

Comment 7

8 years ago
I suspect that Timeless said it wasn't fixed because the original bug report pertained to 3.0.1 and when I filed this (549105) report, it pertained to 3.0.2.  I suspect that those more expert than I believed that if it had been truly fixed in 3.0.1 I would not be experiencing it in 3.0.2.
(Assignee)

Updated

7 years ago
Crash Signature: [@ arena_malloc_small] [@ orkinHeap::Alloc - morkNext::MakeNewNext]
You need to log in before you can comment on or make changes to this bug.