Closed Bug 549113 Opened 11 years ago Closed 11 years ago

MS HTML5 test failed: DOM local storage: "getItem Method with empty string as a key"

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 510849

People

(Reporter: znerd, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9.2) Gecko/20100115 Firefox/3.6

According to the Microsoft HTML5 test suite, Firefox 3.6 fails one of the DOM localStorage tests: "getItem Method with empty string as a key".

Reproducible: Always

Steps to Reproduce:
1. Go to the indicated URL
Actual Results:  
FAIL

Expected Results:  
PASS

See the list of tests, at:
http://samples.msdn.microsoft.com/ietestcenter/html5.htm
I try this under linux with Firefox 3.6.3 and the test FAIL.
All other test are ok. Try them at:
http://samples.msdn.microsoft.com/ietestcenter/html5.htm
All other test are ok. Try them at:
http://samples.msdn.microsoft.com/ietestcenter/html5.htm
I retried with Firefox 3.6.3 on Mac OS X 10.6.3 and again the test failed in a reproducible manner (I tried about 5 times without restarting the browser).
@Malix: Not all other tests succeed, there is another one that failed for me, which may be covered by bug #532062. I added a comment there.
Thanks for the report.

This is already tracked in bug 510849.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 510849
You need to log in before you can comment on or make changes to this bug.