autofill auto fill dropdown form fill sort order broken for dates.

RESOLVED DUPLICATE of bug 531044

Status

()

RESOLVED DUPLICATE of bug 531044
9 years ago
9 years ago

People

(Reporter: davwheat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Using autofill in form, dropdown list of previously entered dates in ISO format (2010/02/27) is not sorted in date order. Appears to be sorted in different order each time form fill entry is attempted.

Reproducible: Always

Steps to Reproduce:
1. Enter a date in a form in ISO format e.g. 2010/02/27
2. Repeat with different dates until you have a dropdown list when you start to enter "2" in that form field.
3. Note that the proposed entries remembered by autofill are in random (?) order, or at least not in date order.
Actual Results:  
dates in dropdown list appear:
2010/02/18
2010/02/25
2010/02/11
2010/02/23
2010/02/24
2010/02/19

Expected Results:  
should have been sorted:
2010/02/11
2010/02/18
2010/02/19
2010/02/23
2010/02/24
2010/02/25

using default theme
Autofill worked fine in previous versions, until I upgraded to 3.6
Observe this problem in 3.6 only
The entries are sorted by frecency starting in Firefox 3.6.  It seems like you want the option to sort alphabetically again.  If so, this is a duplicate of bug 531044.  See bug 531044 comment 1 for more details and a workaround.
Component: Location Bar → Form Manager
OS: Mac OS X → All
Product: Firefox → Toolkit
QA Contact: location.bar → form.manager
Hardware: x86 → All
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> The entries are sorted by frecency starting in Firefox 3.6.  It seems like you
> want the option to sort alphabetically again.  If so, this is a duplicate of
> bug 531044.  See bug 531044 comment 1 for more details and a workaround.

So it's not a bug, it's a "feature". Sigh. But I guess not everyone wants formfill to work the same way. And the majority has ruled. How many users will be willing to even discover about:config, much less edit it?
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531044
You need to log in before you can comment on or make changes to this bug.