If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Deleting the last unread message causes the last previously read message to appear in the message reading tab.

RESOLVED DUPLICATE of bug 505604

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 505604
8 years ago
2 years ago

People

(Reporter: hornetd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

When I delete the last unread message in a given inbox the last undeleted but already read message appears as if it were unread.  In previous versions of TB the message window closed when the last unread message was deleted.  

Reproducible: Always

Steps to Reproduce:
1.Delete the last unread message in a given inbox.  
2.The last read message that was not deleted appears in the message reading tab as if it were unread.  
3.
Actual Results:  
An already read message presents in the message reading tab.  

Expected Results:  
The tab should close OR pop up the "Advance to next unread message in inbox?" query.
I assume you've tried going to Tools -> Options and opening the Advanced section, Reading & Display tab, and checking the box `Close message window on delete`? (If that preference solves your problem, feel free to mark this bug invalid. Otherwise, chances are it's a duplicate.)

I'd like a regression window on this, to verify when and if this behavior disappeared.

Other vaguely similar/related bugs: bug 338112, bug 531534, bug 395151.
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

8 years ago
Nathan
I checked those settings and they are set as you describe but the behavior of the program has not changed.  
--
Tom Horne

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 505604
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.