[SeaMonkey] check: new TestTimeStamp.cpp check intermittently "TEST-UNEXPECTED-FAIL | Time resolution is sane"

RESOLVED DUPLICATE of bug 541185

Status

()

defect
RESOLVED DUPLICATE of bug 541185
10 years ago
7 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

(Blocks 1 bug, {intermittent-failure})

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1267332432.1267337128.7947.gz
Linux comm-central-trunk leak test build on 2010/02/27 20:47:12
{
[...]
TEST-PASS | TimeStamp negative difference upper bound
 (platform timer resolution is ~1e-09 s)
TEST-UNEXPECTED-FAIL | Time resolution is sane
TEST-PASS | Time resolution as good as NSPR's worst
Finished running nsTimeStamp tests.
}
Fwiw, this box also always reports
{
WARNING: the clock resolution is *not* 1ns, something's wrong: file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/xpcom/ds/TimeStamp_posix.cpp, line 108
}

Notes:
*Might be related to bug 541185.
*Might be related to (our computer or) Parallels: we always had timing issues, especially on MacOSX (which now run on minis not VMs anymore).
This is due to the same underlying issue as bug 541185.
Want RESO -> SUBSUMED.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541185
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.